Skip to content
Laskyr

Plugins · foosales · data as of 2026-11-04

Is FooSales safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.43.11)

As of 2026-11-04. 2 issues are on record for older versions; version 1.43.9 or newer fixes all of them that state a fix.

Latest version
1.43.11
Last updated
2026-11-02
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

FooSales® POS turns any device into a retail checkout for WooCommerce. Sync products, orders, and customers with integrated Square and Stripe support. — by FooSales

What to do

  1. Update to the latest version (1.43.11). Anything older than 1.43.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get foosales --field=version shows what you run; wp plugin update foosales updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-77183 · published 2026-10-10

Privilege escalation in FooSales (1.43.0 and older)

Affected
1.43.0 and older
Fixed in
1.43.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FooSales – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.43.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with FooSales Cashier-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.

NVD CVE-2026-77183Wordfence advisoryCode change (fix)

high 8.8 CVE-2026-93548 · published 2026-10-09

Privilege escalation in FooSales (older than 1.43.3)

Affected
older than 1.43.3
Fixed in
1.43.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The FooSales WordPress plugin before 1.43.3 does not verify that an authenticated caller is entitled to act as the user a request names, allowing any authenticated user to have the FooSales WordPress plugin before 1.43.3 act as an arbitrary other user, including an administrator, resulting in that user's account details being exposed and their account being taken over.

NVD CVE-2026-93548WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FooSales vulnerability status badge
<a href="https://laskyr.com/plugins/foosales"><img src="https://laskyr.com/plugins/foosales/badge.svg" alt="FooSales vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit