Plugins · font-awesome · data as of 2026-11-01
Is Font Awesome safe? Known vulnerabilities and latest version
- Latest version
- 5.2.1
- Last updated
- 2026-08-13
- Active installs
- 400,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The official way to use Font Awesome Free or Pro icons on your WordPress site, brought to you by the Font Awesome team. — by fontawesome
What to do
- Update to the latest version (5.2.1). Anything older than 4.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get font-awesome --field=version shows what you run; wp plugin update font-awesome updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2022-4478 · published 2023-01-16
Stored cross-site scripting (XSS) in Font Awesome (older than 4.3.2)
- Affected
- older than 4.3.2
- Fixed in
- 4.3.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Font Awesome WordPress plugin before 4.3.2 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.
Recent activity
- 2026-08-13 — latest release on wordpress.org (5.2.1).
- 2023-01-16 — Stored cross-site scripting (XSS) disclosed (CVE-2022-4478), fixed in 4.3.2.
Get an email when Font Awesome has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Font Awesome (font-awesome) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/font-awesome (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/font-awesome"><img src="https://laskyr.com/plugins/font-awesome/badge.svg" alt="Font Awesome vulnerability status"></a>