Plugins · follow-my-blog-post · data as of 2026-11-04
Is Follow My Blog Post safe? Known vulnerabilities and latest version
- Status
- Closed 2012-08-23
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate follow-my-blog-post && wp plugin delete follow-my-blog-post
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
high 7.5 CVE-2025-68547 · published 2026-01-05
Missing authorization check in Follow My Blog Post (2.4.0 and older)
- Affected
- 2.4.0 and older
- Fixed in
- 2.4.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in wpweb Follow My Blog Post follow-my-blog-post allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Follow My Blog Post: from n/a through <= 2.4.0.
high 7.5 CVE-2025-64258 · published 2025-12-18
Information disclosure in Follow My Blog Post (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.4.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in wpweb Follow My Blog Post follow-my-blog-post allows Retrieve Embedded Sensitive Data.This issue affects Follow My Blog Post: from n/a through <= 2.3.9.
Recent activity
- 2012-08-23 — closed on wordpress.org (Unknown).
- 2026-01-05 — Missing authorization check disclosed (CVE-2025-68547), fixed in 2.4.1.
- 2025-12-18 — Information disclosure disclosed (CVE-2025-64258), fixed in 2.4.0.
Get an email when Follow My Blog Post has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Follow My Blog Post (follow-my-blog-post) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/follow-my-blog-post (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/follow-my-blog-post"><img src="https://laskyr.com/plugins/follow-my-blog-post/badge.svg" alt="Follow My Blog Post vulnerability status"></a>