Skip to content
Laskyr

Plugins · flying-scripts · data as of 2026-11-04

Is Flying Scripts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.5)

As of 2026-11-04. 1 issue is on record for older versions; version 1.2.5 or newer fixes all of them that state a fix.

Latest version
1.2.5
Last updated
2026-10-10
Active installs
30,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Delay JavaScript to improve speed and performance by loading scripts only when needed, reducing render-blocking for a faster and smoother user experie … — by Gijo Varghese

What to do

  1. Update to the latest version (1.2.5). Anything older than 1.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get flying-scripts --field=version shows what you run; wp plugin update flying-scripts updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-109990 · published 2026-10-16

Stored cross-site scripting (XSS) in Flying Scripts (1.2.4 and older)

Affected
1.2.4 and older
Fixed in
1.2.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Flying Scripts: Delay JavaScript to Improve Site Speed & Performance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 1.2.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit bypasses WordPress core's save-time kses sanitization entirely because the payload uses only kses-allowed elements — an <abbr title> attribute and <code> text content — and the XSS is introduced post-save when the plugin's output-buffer rewriter substitutes a double-quote-bearing <code> body into the <abbr title> attribute via predictable, unsalted ___noise___ placeholder keys.

NVD CVE-2026-109990Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Flying Scripts vulnerability status badge
<a href="https://laskyr.com/plugins/flying-scripts"><img src="https://laskyr.com/plugins/flying-scripts/badge.svg" alt="Flying Scripts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit