Skip to content
Laskyr

Plugins · fluent-smtp · data as of 2026-11-01

Is FluentSMTP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.1)

As of 2026-11-01. 4 issues are on record for older versions; version 2.3.0 or newer fixes all of them that state a fix.

Latest version
2.4.1
Last updated
2026-09-27
Active installs
700,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free WP Mail SMTP plugin. Fix WordPress email deliverability with Gmail, Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, Brevo or any SMTP. — by WPManageNinja

What to do

  1. Update to the latest version (2.4.1). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fluent-smtp --field=version shows what you run; wp plugin update fluent-smtp updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-16636 · published 2026-08-06

Stored cross-site scripting (XSS) in FluentSMTP (2.2.95 and older)

Affected
2.2.95 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Recipient Display Name (to.name) in Email Logs in all versions up to, and including, 2.2.95 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is delivered via an attacker-controlled recipient display name (to.name) in a wp_mail() call and does not fire in the log list view — only in the detail view when an administrator uses the Prev/Next navigation controls, as that path bypasses the escapeHtml pipeline used by the list view.

NVD CVE-2026-16636Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-24739 · published 2025-01-24

Cross-site request forgery (CSRF) in FluentSMTP (2.2.80 and older)

Affected
2.2.80 and older
Fixed in
2.2.81
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Shahjahan Jewel FluentSMTP fluent-smtp allows Cross Site Request Forgery.This issue affects FluentSMTP: from n/a through <= 2.2.80.

NVD CVE-2025-24739Patchstack advisory

critical 9.8 CVE-2024-9511 · published 2024-11-23

PHP object injection in FluentSMTP (2.2.82 and older)

Affected
2.2.82 and older
Fixed in
2.2.83 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.2.82 via deserialization of untrusted input in the 'formatResult' function. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. The vulnerability was partially patched in version 2.2.82.

NVD CVE-2024-9511Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2023-3087 · published 2023-07-12

Stored cross-site scripting (XSS) in FluentSMTP (2.2.4 and older)

Affected
2.2.4 and older
Fixed in
2.2.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The FluentSMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via an email subject in versions up to, and including, 2.2.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-3087Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FluentSMTP vulnerability status badge
<a href="https://laskyr.com/plugins/fluent-smtp"><img src="https://laskyr.com/plugins/fluent-smtp/badge.svg" alt="FluentSMTP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit