Skip to content
Laskyr

Plugins · fluent-security · data as of 2026-11-04

Is FluentAuth safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.0 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2026-11-03
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Two-factor authentication, passkeys, social login, magic login, limit login attempts, file change scanning and audit logs for WordPress. — by WPManageNinja

What to do

  1. Update to the latest version (3.1.1). Anything older than 3.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fluent-security --field=version shows what you run; wp plugin update fluent-security updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-78296 · published 2026-09-17

Security issue in FluentAuth (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
3.0.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insufficient Verification of Data Authenticity vulnerability in WP ManageNinja LLC FluentAuth allows Identity Spoofing. This issue affects FluentAuth: from n/a through 2.1.2.

NVD CVE-2026-78296Patchstack advisory

medium 6.4 CVE-2025-13728 · published 2025-12-15

Stored cross-site scripting (XSS) in FluentAuth (2.0.3 and older)

Affected
2.0.3 and older
Fixed in
2.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentAuth – The Ultimate Authorization & Security Plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `fluent_auth_reset_password` shortcode in all versions up to, and including, 2.0.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13728Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FluentAuth vulnerability status badge
<a href="https://laskyr.com/plugins/fluent-security"><img src="https://laskyr.com/plugins/fluent-security/badge.svg" alt="FluentAuth vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit