Skip to content
Laskyr

Plugins · fluent-cart · data as of 2026-11-04

Is FluentCart safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.0)

As of 2026-11-04. 6 issues are on record for older versions; version 1.8.0 or newer fixes all of them that state a fix.

Latest version
2.3.0
Last updated
2026-11-03
Active installs
9,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

eCommerce plugin for online stores, subscriptions, digital downloads & software licensing. Including checkout, payments, tax, and zero commissions. — by WPManageNinja

What to do

  1. Update to the latest version (2.3.0). Anything older than 1.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fluent-cart --field=version shows what you run; wp plugin update fluent-cart updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-120577 · published 2026-11-03

Arbitrary file deletion in FluentCart (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the deleteFile function in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with custom-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2026-120577Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-103525 · published 2026-10-16

Missing authorization check in FluentCart (1.7.0 and older)

Affected
1.7.0 and older
Fixed in
1.7.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.7.0 via the 'order_id + billing_address_id (also shipping_address_id)' parameter due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to read and exfiltrate another customer's stored billing and shipping address PII — including street address, city, state, postcode, phone number, company name, VAT number, and legal registration ID — by enumerating sequential AUTO_INCREMENT order and address ID pairs. The id-equality guard intended to restrict address reuse is bypassed because the attacker controls both halves of the compared pair, and the unauthenticated AJAX entry point imposes only a soft rate limit of 5 requests per 60 seconds rather than any authentication or ownership check.

NVD CVE-2026-103525Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2026-103518 · published 2026-10-16

SQL injection in FluentCart (1.7.0 and older)

Affected
1.7.0 and older
Fixed in
1.7.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin for WordPress is vulnerable to generic SQL Injection via the 'products[*].variants[*].<attacker-chosen key>' parameter in all versions up to, and including, 1.7.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with custom-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. On FluentCart Pro installs, non-administrator users assigned the Manager shop role also hold the products/edit permission and are therefore able to exploit this vulnerability without administrator-level access.

NVD CVE-2026-103518Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.5 CVE-2026-109695 · published 2026-10-15

Information disclosure in FluentCart (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.8.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in WPManageNinja FluentCart fluent-cart allows Retrieve Embedded Sensitive Data.This issue affects FluentCart: from n/a through 1.7.1.

NVD CVE-2026-109695Patchstack advisory

high 7.1 CVE-2025-67971 · published 2026-02-20

Reflected cross-site scripting (XSS) in FluentCart (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPManageNinja FluentCart fluent-cart allows Reflected XSS.This issue affects FluentCart: from n/a through < 1.3.0.

NVD CVE-2025-67971Patchstack advisory

medium 4.9 CVE-2025-13495 · published 2025-12-03

SQL injection in FluentCart (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FluentCart plugin for WordPress is vulnerable to SQL Injection via the 'groupKey' parameter in all versions up to, and including, 1.3.1. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-13495Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FluentCart vulnerability status badge
<a href="https://laskyr.com/plugins/fluent-cart"><img src="https://laskyr.com/plugins/fluent-cart/badge.svg" alt="FluentCart vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit