Skip to content
Laskyr

Plugins · fluent-booking · data as of 2026-11-04

Is Fluent Booking safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.0)

As of 2026-11-04. 5 issues are on record for older versions; version 2.1.2 or newer fixes all of them that state a fix.

Latest version
2.5.0
Last updated
2026-09-24
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The ultimate solution for booking appointments, meetings, webinars, events, sales calls, and more. — by WPManageNinja

What to do

  1. Update to the latest version (2.5.0). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fluent-booking --field=version shows what you run; wp plugin update fluent-booking updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-9576 · published 2026-06-30

Missing authorization check in Fluent Booking (older than 2.1.2)

Affected
older than 2.1.2
Fixed in
2.1.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Fluent Booking WordPress plugin before 2.1.2 does not verify ownership of the requested group_id before exporting attendee data via the export endpoint, allowing users with at least the Calendar Manager role to retrieve attendees' PII (name, email, phone, address, payment information) from calendar groups they do not own.

NVD CVE-2026-9576WPScan advisory

medium 6.5 CVE-2026-57638 · published 2026-06-26

Cross-site scripting (XSS) in Fluent Booking (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Fluent Booking <= 2.1.0 versions.

NVD CVE-2026-57638Patchstack advisory

high 7.2 CVE-2026-2231 · published 2026-03-26

Stored cross-site scripting (XSS) in Fluent Booking (2.0.01 and older)

Affected
2.0.01 and older
Fixed in
2.0.05 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fluent Booking plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple parameters in all versions up to, and including, 2.0.01 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2231Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-67597 · published 2025-12-09

Missing authorization check in Fluent Booking (1.9.11 and older)

Affected
1.9.11 and older
Fixed in
1.10.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Shahjahan Jewel Fluent Booking fluent-booking allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Fluent Booking: from n/a through <= 1.9.11.

NVD CVE-2025-67597Patchstack advisory

medium 4.3 CVE-2025-13756 · published 2025-12-03

Missing authorization check in Fluent Booking (1.9.11 and older)

Affected
1.9.11 and older
Fixed in
1.10.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fluent Booking plugin for WordPress is vulnerable to unauthorized calendar import and management due to a missing capability check on the "importCalendar" function in all versions up to, and including, 1.9.11. This makes it possible for authenticated attackers, with subscriber level access and above, to import arbitrary calendars and manage them.

NVD CVE-2025-13756Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fluent Booking vulnerability status badge
<a href="https://laskyr.com/plugins/fluent-booking"><img src="https://laskyr.com/plugins/fluent-booking/badge.svg" alt="Fluent Booking vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit