Skip to content
Laskyr

Plugins · fluent-boards · data as of 2026-11-04

Is FluentBoards safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.0)

As of 2026-11-04. 5 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.3.0
Last updated
2026-10-30
Active installs
6,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The Simplest Project & Task Management Plugin Specifically Crafted for Agencies, Freelancers & Founders. — by Mahmudul Hasan Arif

What to do

  1. Update to the latest version (2.3.0). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fluent-boards --field=version shows what you run; wp plugin update fluent-boards updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-109696 · published 2026-10-13

Missing authorization check in FluentBoards (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP ManageNinja LLC FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through 2.1.0.

NVD CVE-2026-109696Patchstack advisory

medium 6.3 CVE-2026-96821 · published 2026-09-30

Privilege escalation in FluentBoards (2.0.12 and older)

Affected
2.0.12 and older
Fixed in
2.0.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Privilege Escalation in FluentBoards <= 2.0.12 versions.

NVD CVE-2026-96821Patchstack advisory

high 8.1 CVE-2026-40784 · published 2026-04-15

Missing authorization check in FluentBoards (1.91.2 and older)

Affected
1.91.2 and older
Fixed in
1.91.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through <= 1.91.2.

NVD CVE-2026-40784Patchstack advisory

medium 5.4 CVE-2026-24561 · published 2026-01-23

Missing authorization check in FluentBoards (1.91.1 and older)

Affected
1.91.1 and older
Fixed in
1.9.1.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through <= 1.91.1.

NVD CVE-2026-24561Patchstack advisory

critical 9.8 CVE-2025-39551 · published 2025-04-17

PHP object injection in FluentBoards (1.47 and older)

Affected
1.47 and older
Fixed in
1.48
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Object Injection.This issue affects FluentBoards: from n/a through <= 1.47.

NVD CVE-2025-39551Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FluentBoards vulnerability status badge
<a href="https://laskyr.com/plugins/fluent-boards"><img src="https://laskyr.com/plugins/fluent-boards/badge.svg" alt="FluentBoards vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit