Plugins · flo-forms · data as of 2026-11-04
Is Flo Forms safe? Known vulnerabilities and latest version
- Status
- Closed 2025-11-18
- Known issues on record
- 6
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate flo-forms && wp plugin delete flo-forms
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 6 record(s) do not state which versions are affected.
high 7.1 CVE-2025-13159 · published 2025-11-21
Stored cross-site scripting (XSS) in Flo Forms (1.0.43 and older)
- Affected
- 1.0.43 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flo Forms – Easy Drag & Drop Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in all versions up to, and including, 1.0.43. This is due to the plugin allowing SVG file uploads via an unauthenticated AJAX endpoint (`flo_form_submit`) without proper file content validation. This makes it possible for unauthenticated attackers to upload malicious SVG files containing JavaScript that executes when an administrator views the uploaded file in the WordPress admin interface, leading to potential full site compromise.
medium 6.5 CVE-2025-32213 · published 2025-04-10
Missing authorization check in Flo Forms (1.0.43 and older)
- Affected
- 1.0.43 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in flothemesplugins Flo Forms flo-forms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Flo Forms: from n/a through <= 1.0.43.
medium 4.3 CVE-2023-47692 · published 2025-01-02
Missing authorization check in Flo Forms (1.0.41 and older)
- Affected
- 1.0.41 and older
- Fixed in
- 1.0.42
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in flothemesplugins Flo Forms flo-forms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Flo Forms: from n/a through <= 1.0.41.
medium 5.3 CVE-2024-35174 · published 2024-05-17
Missing authorization check in Flo Forms (1.0.42 and older)
- Affected
- 1.0.42 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Flothemes Flo Forms.This issue affects Flo Forms: from n/a through 1.0.42.
medium 4.8 CVE-2023-35095 · published 2023-06-20
Stored cross-site scripting (XSS) in Flo Forms (1.0.40 and older)
- Affected
- 1.0.40 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Flothemes Flo Forms – Easy Drag & Drop Form Builder plugin <= 1.0.40 versions.
medium 5.4 CVE-2021-4367 · published 2023-06-07
Stored cross-site scripting (XSS) in Flo Forms (1.0.35 and older)
- Affected
- 1.0.35 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Flo Forms – Easy Drag & Drop Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Options Change by using the flo_import_forms_options AJAX action in versions up to, and including, 1.0.35 due to insufficient input sanitization and output escaping along with missing capability checks. This makes it possible for authenticated attackers, like subscribers, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2021-4367Wordfence advisoryWPScan advisoryblog.nintechnet.com
Recent activity
- 2025-11-18 — closed on wordpress.org (Security Issue).
- 2025-11-21 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13159), fix version not stated.
- 2025-04-10 — Missing authorization check disclosed (CVE-2025-32213), fix version not stated.
- 2025-01-02 — Missing authorization check disclosed (CVE-2023-47692), fixed in 1.0.42.
Get an email when Flo Forms has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Flo Forms (flo-forms) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (3)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/flo-forms (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/flo-forms"><img src="https://laskyr.com/plugins/flo-forms/badge.svg" alt="Flo Forms vulnerability status"></a>