Plugins · flexmls-idx · data as of 2026-11-04
Is Flexmls® IDX Plugin safe? Known vulnerabilities and latest version
- Latest version
- 4.1.2
- Last updated
- 2026-10-05
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Add Flexmls® IDX listings, market statistics, IDX searches, and a contact form on your web site. — by flexmls
What to do
- Update to the latest version (4.1.2). Anything older than 3.15.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get flexmls-idx --field=version shows what you run; wp plugin update flexmls-idx updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-25369 · published 2026-03-16
Reflected cross-site scripting (XSS) in Flexmls® IDX Plugin (3.15.9 and older)
- Affected
- 3.15.9 and older
- Fixed in
- 3.15.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in flexmls Flexmls® IDX flexmls-idx allows Reflected XSS.This issue affects Flexmls® IDX: from n/a through <= 3.15.9.
medium 4.7 CVE-2025-67585 · published 2025-12-09
Open redirect in Flexmls® IDX Plugin (3.15.7 and older)
- Affected
- 3.15.7 and older
- Fixed in
- 3.15.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in flexmls Flexmls® IDX flexmls-idx allows Phishing.This issue affects Flexmls® IDX: from n/a through <= 3.15.7.
medium 6.4 CVE-2025-0863 · published 2025-03-07
Stored cross-site scripting (XSS) in Flexmls® IDX Plugin (3.14.28 and older)
- Affected
- 3.14.28 and older
- Fixed in
- 3.14.29 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flexmls® IDX Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'idx_frame' shortcode in all versions up to, and including, 3.14.27 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-0863Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2025-26900 · published 2025-02-25
PHP object injection in Flexmls® IDX Plugin (3.14.27 and older)
- Affected
- 3.14.27 and older
- Fixed in
- 3.14.28
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in flexmls Flexmls® IDX flexmls-idx allows Object Injection.This issue affects Flexmls® IDX: from n/a through <= 3.14.27.
medium 6.4 CVE-2024-10552 · published 2025-01-25
Stored cross-site scripting (XSS) in Flexmls® IDX Plugin (3.14.26 and older)
- Affected
- 3.14.26 and older
- Fixed in
- 3.14.27 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flexmls® IDX Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘api_key’ and 'api_secret' parameters in all versions up to, and including, 3.14.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 3.14.25.
NVD CVE-2024-10552Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-8719 · published 2024-10-17
Reflected cross-site scripting (XSS) in Flexmls® IDX Plugin (3.14.22 and older)
- Affected
- 3.14.22 and older
- Fixed in
- 3.14.23 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flexmls® IDX Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via several parameters like 'MaxBeds' and 'MinBeds' in all versions up to, and including, 3.14.22 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Recent activity
- 2026-10-05 — latest release on wordpress.org (4.1.2).
- 2026-03-16 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-25369), fixed in 3.15.10.
- 2025-12-09 — Open redirect disclosed (CVE-2025-67585), fixed in 3.15.8.
- 2025-03-07 — Stored cross-site scripting (XSS) disclosed (CVE-2025-0863), fixed in 3.14.29.
Get an email when Flexmls® IDX Plugin has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Flexmls® IDX Plugin (flexmls-idx) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Open redirect (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/flexmls-idx (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/flexmls-idx"><img src="https://laskyr.com/plugins/flexmls-idx/badge.svg" alt="Flexmls® IDX Plugin vulnerability status"></a>