Skip to content
Laskyr

Plugins · flexible-subscriptions · data as of 2026-11-04

Is Flexible Subscriptions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.8.5 or newer fixes all of them that state a fix.

Latest version
1.8.9
Last updated
2026-10-22
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Meet Flexible Subscriptions for WooCommerce. The best & free plugin for recurring payments and subscriptions in WooCommerce. — by wpdesk

What to do

  1. Update to the latest version (1.8.9). Anything older than 1.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get flexible-subscriptions --field=version shows what you run; wp plugin update flexible-subscriptions updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-107869 · published 2026-10-12

Missing authorization check in Flexible Subscriptions (1.8.4 and older)

Affected
1.8.4 and older
Fixed in
1.8.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Desk Flexible Subscriptions flexible-subscriptions allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Flexible Subscriptions: from n/a through 1.8.4.

NVD CVE-2026-107869Patchstack advisory

critical 9.8 CVE-2026-73364 · published 2026-08-19

PHP object injection in Flexible Subscriptions (1.8.1 and older)

Affected
1.8.1 and older
Fixed in
1.8.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Customer PHP Object Injection in Flexible Subscriptions <= 1.8.1 versions.

NVD CVE-2026-73364Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Flexible Subscriptions vulnerability status badge
<a href="https://laskyr.com/plugins/flexible-subscriptions"><img src="https://laskyr.com/plugins/flexible-subscriptions/badge.svg" alt="Flexible Subscriptions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit