Plugins · flexible-refund-and-return-order-for-woocommerce · data as of 2026-11-04
Is Flexible Refund for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 2.1.1
- Last updated
- 2026-11-03
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
WooCommerce refund and returns process made simple. Let your customers request a refund and return products directly from the My Account page. — by wpdesk
What to do
- Update to the latest version (2.1.1). Anything older than 1.0.52 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get flexible-refund-and-return-order-for-woocommerce --field=version shows what you run; wp plugin update flexible-refund-and-return-order-for-woocommerce updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-57402 · published 2026-07-13
Stored cross-site scripting (XSS) in Flexible Refund for WooCommerce (1.0.51 and older)
- Affected
- 1.0.51 and older
- Fixed in
- 1.0.52
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdesk Flexible Refund and Return Order for WooCommerce flexible-refund-and-return-order-for-woocommerce allows Stored XSS.This issue affects Flexible Refund and Return Order for WooCommerce: from n/a through <= 1.0.51.
medium 5.3 CVE-2025-12621 · published 2025-11-08
Missing authorization check in Flexible Refund for WooCommerce (1.0.42 and older)
- Affected
- 1.0.42 and older
- Fixed in
- 1.0.43 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flexible Refund and Return Order for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a misconfigured capability check on the 'create_refund' function in all versions up to, and including, 1.0.42. This makes it possible for authenticated attackers, with Contributor-level access and above, to update the status of refund requests, including approving and refusing refunds.
NVD CVE-2025-12621Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-10570 · published 2025-10-22
Missing authorization check in Flexible Refund for WooCommerce (1.0.38 and older)
- Affected
- 1.0.38 and older
- Fixed in
- 1.0.39 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flexible Refund and Return Order for WooCommerce plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.0.38 via the save_refund_request() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to submit refund requests for arbitrary orders that they do not own.
Recent activity
- 2026-11-03 — latest release on wordpress.org (2.1.1).
- 2026-07-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-57402), fixed in 1.0.52.
- 2025-11-08 — Missing authorization check disclosed (CVE-2025-12621), fixed in 1.0.43.
- 2025-10-22 — Missing authorization check disclosed (CVE-2025-10570), fixed in 1.0.39.
Get an email when Flexible Refund for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Flexible Refund for WooCommerce (flexible-refund-and-return-order-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by wpdesk (8 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/flexible-refund-and-return-order-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/flexible-refund-and-return-order-for-woocommerce"><img src="https://laskyr.com/plugins/flexible-refund-and-return-order-for-woocommerce/badge.svg" alt="Flexible Refund for WooCommerce vulnerability status"></a>