Skip to content
Laskyr

Plugins · flexible-coupons · data as of 2026-11-04

Is Flexible PDF Coupons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.14.12)

As of 2026-11-04. 2 issues are on record for older versions; version 1.14.12 or newer fixes all of them that state a fix.

Latest version
1.14.12
Last updated
2026-09-22
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Flexible PDF Coupons - Gift Cards & Vouchers for WooCommerce - plugin to design and sell PDF gift cards, vouchers, or coupons in your store. — by wpdesk

What to do

  1. Update to the latest version (1.14.12). Anything older than 1.14.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get flexible-coupons --field=version shows what you run; wp plugin update flexible-coupons updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-62081 · published 2026-09-30

Missing authorization check in Flexible PDF Coupons (1.14.11 and older)

Affected
1.14.11 and older
Fixed in
1.14.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Insecure Direct Object References (IDOR) in Flexible PDF Coupons <= 1.14.11 versions.

NVD CVE-2026-62081Patchstack advisory

medium 6.5 CVE-2025-22825 · published 2025-01-21

Stored cross-site scripting (XSS) in Flexible PDF Coupons (1.10.3 and older)

Affected
1.10.3 and older
Fixed in
1.10.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdesk Flexible PDF Coupons flexible-coupons allows Stored XSS.This issue affects Flexible PDF Coupons: from n/a through < 1.10.3.

NVD CVE-2025-22825Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Flexible PDF Coupons vulnerability status badge
<a href="https://laskyr.com/plugins/flexible-coupons"><img src="https://laskyr.com/plugins/flexible-coupons/badge.svg" alt="Flexible PDF Coupons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit