Plugins · flex-qr-code-generator · data as of 2026-11-04
Is Flex QR Code Generator safe? Known vulnerabilities and latest version
- Latest version
- 1.2.12
- Last updated
- 2026-08-01
- Active installs
- 90+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4.2+
Generate customized or automated Nice QR codes for pages, posts or products and show the qrcode with shortcode, widget or block. — by Devsbrain
What to do
- Update to the latest version (1.2.12). Anything older than 1.2.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get flex-qr-code-generator --field=version shows what you run; wp plugin update flex-qr-code-generator updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2026-24614 · published 2026-01-23
Cross-site scripting (XSS) in Flex QR Code Generator (1.2.10 and older)
- Affected
- 1.2.10 and older
- Fixed in
- 1.2.11 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Devsbrain Flex QR Code Generator flex-qr-code-generator allows DOM-Based XSS.This issue affects Flex QR Code Generator: from n/a through <= 1.2.10.
critical 9.8 CVE-2025-12673 · published 2025-12-06
Arbitrary file upload in Flex QR Code Generator (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flex QR Code Generator plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the update_qr_code() function in all versions up to, and including, 1.2.7. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
NVD CVE-2025-12673Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source
critical 9.8 CVE-2025-10041 · published 2025-10-15
Arbitrary file upload in Flex QR Code Generator (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.2.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Flex QR Code Generator plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in thesave_qr_code_to_db() function in all versions up to, and including, 1.2.5. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
NVD CVE-2025-10041Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-08-01 — latest release on wordpress.org (1.2.12).
- 2026-01-23 — Cross-site scripting (XSS) disclosed (CVE-2026-24614), fixed in 1.2.11.
- 2025-12-06 — Arbitrary file upload disclosed (CVE-2025-12673), fixed in 1.2.8.
- 2025-10-15 — Arbitrary file upload disclosed (CVE-2025-10041), fixed in 1.2.6.
Get an email when Flex QR Code Generator has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Flex QR Code Generator (flex-qr-code-generator) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Devsbrain (3 tracked)
Types found in this plugin: Arbitrary file upload (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/flex-qr-code-generator (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/flex-qr-code-generator"><img src="https://laskyr.com/plugins/flex-qr-code-generator/badge.svg" alt="Flex QR Code Generator vulnerability status"></a>