Skip to content
Laskyr

Plugins · flex-import · data as of 2026-11-04

Is Flex Import safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1)

As of 2026-11-04. 1 issue is on record for older versions; version 3.1 or newer fixes all of them that state a fix.

Latest version
3.1
Last updated
2026-08-01
Active installs
500+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.2+

Flex Import is a powerful one-click demo importer plugin built to supercharge your website setup experience. — by flextheme

What to do

  1. Update to the latest version (3.1). Anything older than 3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get flex-import --field=version shows what you run; wp plugin update flex-import updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9615 · published 2026-09-19

Missing authorization check in Flex Import (3.0 and older)

Affected
3.0 and older
Fixed in
3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Flex Import plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.0. This is due to the license_activate_fleximp() and license_deactivate_fleximp() functions, hooked to the wp_ajax_license_activate_fleximp and wp_ajax_license_deactivate_fleximp AJAX actions, lacking both a capability check (current_user_can()) and nonce verification (the client-side script sends a 'wpnonce' value but the handlers never validate it). This makes it possible for authenticated attackers, with subscriber-level access and above, to activate an arbitrary/fraudulent license key (persisting it via update_option('fleximp_is_premium') and toggling validation, suspension, and bundle status options) or deactivate the site's legitimate license (deleting the stored key and setting fleximp_validation_status to false), thereby disrupting the plugin's premium functionality.

NVD CVE-2026-9615Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Flex Import vulnerability status badge
<a href="https://laskyr.com/plugins/flex-import"><img src="https://laskyr.com/plugins/flex-import/badge.svg" alt="Flex Import vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit