Plugins · fleet · data as of 2026-11-04
Is Fleet Manager safe? Known vulnerabilities and latest version
- Latest version
- 2.6.1
- Last updated
- 2026-10-14
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 8.0+
Manage sailboats, sailors, regattas, and results with ease. — by iworks (Marcin Pietrzak)
What to do
- Update to the latest version (2.6.1). Anything older than 2.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get fleet --field=version shows what you run; wp plugin update fleet updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2025-12538 · published 2025-11-11
Stored cross-site scripting (XSS) in Fleet Manager (2.5.1 and older)
- Affected
- 2.5.1 and older
- Fixed in
- 2.6.0 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Fleet Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
NVD CVE-2025-12538Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-10-14 — latest release on wordpress.org (2.6.1).
- 2025-11-11 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12538), fixed in 2.6.0.
Get an email when Fleet Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Fleet Manager (fleet) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by iworks (Marcin Pietrzak) (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/fleet (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/fleet"><img src="https://laskyr.com/plugins/fleet/badge.svg" alt="Fleet Manager vulnerability status"></a>