Skip to content
Laskyr

Plugins · flatpm-wp · data as of 2026-11-04

Is FlatPM safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.3)

As of 2026-11-04. 2 issues are on record for older versions; version 3.2.3 or newer fixes all of them that state a fix.

Latest version
3.2.3
Last updated
2026-01-07
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

Flat PM is an ad management plugin. You might be thinking, "why do I need it?". It's simple: this is the best plugin for organizing ads … — by Mikhail Flat

What to do

  1. Update to the latest version (3.2.3). Anything older than 3.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get flatpm-wp --field=version shows what you run; wp plugin update flatpm-wp updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-0690 · published 2026-01-20

Stored cross-site scripting (XSS) in FlatPM (3.2.2 and older)

Affected
3.2.2 and older
Fixed in
3.2.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FlatPM – Ad Manager, AdSense and Custom Code plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'rank_math_description' custom field in all versions up to, and including, 3.2.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0690Wordfence advisoryCode change (fix)

medium 6.5 CVE-2024-29803 · published 2024-03-27

Stored cross-site scripting (XSS) in FlatPM (older than 3.1.05)

Affected
older than 3.1.05
Fixed in
3.1.05
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mehanoid.Pro FlatPM allows Stored XSS.This issue affects FlatPM: from n/a before 3.1.05.

NVD CVE-2024-29803Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FlatPM vulnerability status badge
<a href="https://laskyr.com/plugins/flatpm-wp"><img src="https://laskyr.com/plugins/flatpm-wp/badge.svg" alt="FlatPM vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit