Skip to content
Laskyr

Plugins · filter-plus · data as of 2026-11-04

Is Filter Plus safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.39)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.18 or newer fixes all of them that state a fix.

Latest version
1.1.39
Last updated
2026-11-03
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

AJAX WooCommerce product filter and WordPress post filter. Shoppers filter by price, rating, category, attribute, color and size without reload. — by Wpbens

What to do

  1. Update to the latest version (1.1.39). Anything older than 1.1.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get filter-plus --field=version shows what you run; wp plugin update filter-plus updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-39607 · published 2026-04-08

Missing authorization check in Filter Plus (1.1.17 and older)

Affected
1.1.17 and older
Fixed in
1.1.18 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Wpbens Filter Plus filter-plus allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Filter Plus: from n/a through <= 1.1.17.

NVD CVE-2026-39607Patchstack advisory

medium 5.3 CVE-2025-13314 · published 2025-12-12

Missing authorization check in Filter Plus (1.1.6 and older)

Affected
1.1.6 and older
Fixed in
1.1.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Filtering by Categories, Tags, Price Range for WooCommerce – Filter Plus plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 1.1.6 due to a missing capability check on the 'filter_save_settings' and 'add_filter_options' AJAX actions. This makes it possible for unauthenticated attackers to modify the plugin's settings and create arbitrary filter options.

NVD CVE-2025-13314Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Filter Plus vulnerability status badge
<a href="https://laskyr.com/plugins/filter-plus"><img src="https://laskyr.com/plugins/filter-plus/badge.svg" alt="Filter Plus vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit