Plugins · filter-everything · data as of 2026-11-04
Is Filter Everything safe? Known vulnerabilities and latest version
- Latest version
- 1.9.8
- Last updated
- 2026-11-02
- Active installs
- 50,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The most flexible filters for WooCommerce products & WordPress content. Includes everything needed, supports Elementor & builders, AJAX, quick setup. — by stepasyuk
What to do
- Update to the latest version (1.9.8). Anything older than 1.9.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get filter-everything --field=version shows what you run; wp plugin update filter-everything updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-116390 · published 2026-10-28
PHP object injection in Filter Everything (1.9.7 and older)
- Affected
- 1.9.7 and older
- Fixed in
- 1.9.8 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in stepasyuk Filter Everything — WordPress & WooCommerce Filters filter-everything allows Object Injection.This issue affects Filter Everything — WordPress & WooCommerce Filters: from n/a through 1.9.7.
medium 6.1 CVE-2026-87869 · published 2026-10-10
Reflected cross-site scripting (XSS) in Filter Everything (1.9.6 and older)
- Affected
- 1.9.6 and older
- Fixed in
- 1.9.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Filter Everything — WordPress & WooCommerce Filters plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 1.9.6. This is due to insufficient input sanitization and output escaping in the flrt_elementor_load_more_anchor() function. The function reads query parameters from $_SERVER['REQUEST_URI'] via getFormActionOrFullPageUrl(true), which URL-decodes them through parse_str() and re-assembles them using build_query() — a WordPress core function that does NOT re-encode values ($urlencode=false). The resulting URL, containing unescaped special characters, is injected into a data-next-page HTML attribute via preg_replace() without esc_attr() or esc_url(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a specially crafted link.
NVD CVE-2026-87869Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-02 — latest release on wordpress.org (1.9.8).
- 2026-10-28 — PHP object injection disclosed (CVE-2026-116390), fixed in 1.9.8.
- 2026-10-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-87869), fixed in 1.9.7.
Get an email when Filter Everything has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Filter Everything (filter-everything) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: PHP object injection (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/filter-everything (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/filter-everything"><img src="https://laskyr.com/plugins/filter-everything/badge.svg" alt="Filter Everything vulnerability status"></a>