Skip to content
Laskyr

Plugins · filr-protection · data as of 2026-11-04

Is Filr safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.19)

As of 2026-11-04. 5 issues are on record for older versions; version 1.2.15 or newer fixes all of them that state a fix.

Latest version
1.2.19
Last updated
2026-10-02
Active installs
700+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily Create a Secure Document Library with Filr — by WP Chill

What to do

  1. Update to the latest version (1.2.19). Anything older than 1.2.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get filr-protection --field=version shows what you run; wp plugin update filr-protection updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-28133 · published 2026-03-05

Arbitrary file upload in Filr (1.2.14 and older)

Affected
1.2.14 and older
Fixed in
1.2.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WP Chill Filr filr-protection allows Upload a Web Shell to a Web Server.This issue affects Filr: from n/a through <= 1.2.14.

NVD CVE-2026-28133Patchstack advisory

medium 4.4 CVE-2025-14632 · published 2026-01-17

Stored cross-site scripting (XSS) in Filr (1.2.11 and older)

Affected
1.2.11 and older
Fixed in
1.2.12 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Filr – Secure document library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via unrestricted file upload in all versions up to, and including, 1.2.11 due to insufficient file type restrictions in the FILR_Uploader class. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload malicious HTML files containing JavaScript that will execute whenever a user accesses the uploaded file, granted they have permission to create or edit posts with the 'filr' post type.

NVD CVE-2025-14632Wordfence advisoryCode change (fix)Plugin source

high 7.7 CVE-2025-64230 · published 2025-12-18

Path traversal / file read in Filr (1.2.10 and older)

Affected
1.2.10 and older
Fixed in
1.2.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WP Chill Filr filr-protection allows Path Traversal.This issue affects Filr: from n/a through <= 1.2.10.

NVD CVE-2025-64230Patchstack advisory

medium 6.5 CVE-2024-43216 · published 2024-08-12

Cross-site scripting (XSS) in Filr (1.2.4 and older)

Affected
1.2.4 and older
Fixed in
1.2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Chill Filr filr-protection.This issue affects Filr: from n/a through <= 1.2.4.

NVD CVE-2024-43216Patchstack advisory

high 8.8 CVE-2022-1777 · published 2022-06-13

Missing authorization check in Filr (older than 1.2.2.1)

Affected
older than 1.2.2.1
Fixed in
1.2.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by NVD
Details from the advisory

The Filr WordPress plugin before 1.2.2.1 does not have authorisation check in two of its AJAX actions, allowing them to be called by any authenticated users, such as subscriber. They are are protected with a nonce, however the nonce is leaked on the dashboard. This could allow them to upload arbitrary HTML files as well as delete all files or arbitrary ones.

NVD CVE-2022-1777WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Filr vulnerability status badge
<a href="https://laskyr.com/plugins/filr-protection"><img src="https://laskyr.com/plugins/filr-protection/badge.svg" alt="Filr vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit