Plugins · file-uploader-for-woocommerce · data as of 2026-11-04
Is File Uploader for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.0.5
- Last updated
- 2026-08-06
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.4+
Allows to attach files from different sources to WooCommerce customer orders. — by Snowray Software
What to do
- Update to the latest version (1.0.5). Anything older than 1.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get file-uploader-for-woocommerce --field=version shows what you run; wp plugin update file-uploader-for-woocommerce updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-25397 · published 2026-03-25
Path traversal / file read in File Uploader for WooCommerce (1.0.4 and older)
- Affected
- 1.0.4 and older
- Fixed in
- 1.0.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Path Traversal: '.../...//' vulnerability in Snowray Software File Uploader for WooCommerce file-uploader-for-woocommerce allows Path Traversal.This issue affects File Uploader for WooCommerce: from n/a through <= 1.0.4.
critical 9.8 CVE-2025-13329 · published 2025-12-20
Arbitrary file upload in File Uploader for WooCommerce (1.0.3 and older)
- Affected
- 1.0.3 and older
- Fixed in
- 1.0.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The File Uploader for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the callback function for the 'add-image-data' REST API endpoint in all versions up to, and including, 1.0.3. This makes it possible for unauthenticated attackers to upload arbitrary files to the Uploadcare service and subsequently download them on the affected site's server which may make remote code execution possible.
NVD CVE-2025-13329Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-08-06 — latest release on wordpress.org (1.0.5).
- 2026-03-25 — Path traversal / file read disclosed (CVE-2026-25397), fixed in 1.0.5.
- 2025-12-20 — Arbitrary file upload disclosed (CVE-2025-13329), fixed in 1.0.4.
Get an email when File Uploader for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for File Uploader for WooCommerce (file-uploader-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Path traversal and file read (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/file-uploader-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/file-uploader-for-woocommerce"><img src="https://laskyr.com/plugins/file-uploader-for-woocommerce/badge.svg" alt="File Uploader for WooCommerce vulnerability status"></a>