Skip to content
Laskyr

Plugins · fense-block-vpn-proxy · data as of 2026-11-04

Is Fense Block Vpn & Proxy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.5)

As of 2026-11-04. 1 issue is on record for older versions; version 3.0.2 or newer fixes all of them that state a fix.

Latest version
3.1.5
Last updated
2026-08-13
Active installs
70+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Blocks Proxies, VPN's, IP's, Ranges & ASN's accessing your site login or commenting on pages & posts using the Fense.in API. — by Devozon

What to do

  1. Update to the latest version (3.1.5). Anything older than 3.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fense-block-vpn-proxy --field=version shows what you run; wp plugin update fense-block-vpn-proxy updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-8616 · published 2026-07-17

Missing authorization check in Fense Block Vpn & Proxy (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.0.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fense Proxy & VPN Blocker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check and missing nonce validation on the fense_bpvt_save_settings() function in versions up to, and including, 3.0.1. The callback is registered to both wp_ajax_* and wp_ajax_nopriv_* hooks and unconditionally calls delete_option() on four plugin options and delete_transient() on three transients tied to the plugin's API key cache and settings. This makes it possible for unauthenticated attackers to delete plugin options and transients, effectively resetting the plugin's API key/data cache and forcing the plugin to refetch state.

NVD CVE-2026-8616Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fense Block Vpn & Proxy vulnerability status badge
<a href="https://laskyr.com/plugins/fense-block-vpn-proxy"><img src="https://laskyr.com/plugins/fense-block-vpn-proxy/badge.svg" alt="Fense Block Vpn & Proxy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit