Plugins · feeds-for-youtube · data as of 2026-11-04
Is Feeds for YouTube (YouTube video, channel, and… safe? Known vulnerabilities and latest version
- Latest version
- 2.11.1
- Last updated
- 2026-11-02
- Active installs
- 100,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The Feeds for YouTube plugin allows you to display customizable YouTube feeds from any YouTube channel. — by Syed Balkhi
What to do
- Update to the latest version (2.11.1). Anything older than 2.6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get feeds-for-youtube --field=version shows what you run; wp plugin update feeds-for-youtube updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-1631 · published 2026-05-18
Missing authorization check in Feeds for YouTube (YouTube video, channel, and… (older than 2.6.4)
- Affected
- older than 2.6.4
- Fixed in
- 2.6.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Feeds for YouTube (YouTube video, channel, and gallery plugin) WordPress plugin before 2.6.4 is vulnerable to unauthorized modification of the Feeds for YouTube (YouTube video, channel, and gallery plugin) WordPress plugin before 2.6.4's license key due to a missing capability check on the 'actions' function. This makes it possible for subscribers and above delete the license key.
medium 5.9 CVE-2025-12002 · published 2026-01-17
Path traversal / file read in Feeds for YouTube (YouTube video, channel, and… (2.6.0 and older)
- Affected
- 2.6.0 and older
- Fixed in
- 2.6.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by Wordfence
Details from the advisory
The Feeds for YouTube Pro plugin for WordPress is vulnerable to arbitrary file read in all versions up to, and including, 2.6.0 via the 'sby_check_wp_submit' AJAX action. This is due to insufficient sanitization of user-supplied data and the use of that data in a file operation. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information, granted the 'Save Featured Images' setting is enabled and 'Disable WP Posts' is disabled. Note: This vulnerability only affects the Pro version of Feeds for YouTube.
NVD CVE-2025-12002Wordfence advisorysmashballoon.comPlugin source
medium 5.3 CVE-2025-64635 · published 2025-12-16
Missing authorization check in Feeds for YouTube (YouTube video, channel, and… (2.4.0 and older)
- Affected
- 2.4.0 and older
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Syed Balkhi Feeds for YouTube feeds-for-youtube allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Feeds for YouTube: from n/a through <= 2.4.0.
medium 5.4 CVE-2024-6256 · published 2024-07-11
Stored cross-site scripting (XSS) in Feeds for YouTube (YouTube video, channel, and… (2.2.1 and older)
- Affected
- 2.2.1 and older
- Fixed in
- 2.2.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Feeds for YouTube (YouTube video, channel, and gallery plugin) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'youtube-feed' shortcode in all versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-6256Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2023-4841 · published 2023-09-14
Stored cross-site scripting (XSS) in Feeds for YouTube (YouTube video, channel, and… (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Feeds for YouTube plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'youtube-feed' shortcode in versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-4841Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.11.1).
- 2026-05-18 — Missing authorization check disclosed (CVE-2026-1631), fixed in 2.6.4.
- 2026-01-17 — Path traversal / file read disclosed (CVE-2025-12002), fixed in 2.6.1.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-64635), fixed in 2.6.1.
Get an email when Feeds for YouTube (YouTube video, channel, and… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Feeds for YouTube (YouTube video, channel, and… (feeds-for-youtube) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Syed Balkhi (28 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/feeds-for-youtube (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/feeds-for-youtube"><img src="https://laskyr.com/plugins/feeds-for-youtube/badge.svg" alt="Feeds for YouTube (YouTube video, channel, and… vulnerability status"></a>