Plugins · featured-post-creative · data as of 2026-11-04
Is Featured Post Creative safe? Known vulnerabilities and latest version
- Status
- Closed 2026-04-07
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate featured-post-creative && wp plugin delete featured-post-creative
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 4.3 CVE-2025-66106 · published 2025-11-21
Missing authorization check in Featured Post Creative (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.5.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Essential Plugin Featured Post Creative featured-post-creative allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Featured Post Creative: from n/a through <= 1.5.5.
medium 5.3 CVE-2023-30488 · published 2024-12-09
Missing authorization check in Featured Post Creative (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP OnlineSupport, Essential Plugin Featured Post Creative allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Featured Post Creative: from n/a through 1.2.7.
Recent activity
- 2026-04-07 — closed on wordpress.org (Security Issue).
- 2025-11-21 — Missing authorization check disclosed (CVE-2025-66106), fixed in 1.5.6.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-30488), fixed in 1.2.8.
Get an email when Featured Post Creative has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Featured Post Creative (featured-post-creative) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/featured-post-creative (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/featured-post-creative"><img src="https://laskyr.com/plugins/featured-post-creative/badge.svg" alt="Featured Post Creative vulnerability status"></a>