Skip to content
Laskyr

Plugins · featured-image · data as of 2026-11-04

Is Featured Image safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2 or newer fixes all of them that state a fix.

Latest version
2.2
Last updated
2025-11-08
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

Add featured image to any part of the website, on each individual post/page. Very Easy to Implement. Shortcode and widget available. — by Mervin Praison

What to do

  1. Update to the latest version (2.2). Anything older than 2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get featured-image --field=version shows what you run; wp plugin update featured-image updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-57431 · published 2026-06-26

Cross-site scripting (XSS) in Featured Image (2.1 and older)

Affected
2.1 and older
Fixed in
2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Author Cross Site Scripting (XSS) in Featured Image <= 2.1 versions.

NVD CVE-2026-57431Patchstack advisory

medium 5.5 CVE-2025-12019 · published 2025-11-11

Stored cross-site scripting (XSS) in Featured Image (2.1 and older)

Affected
2.1 and older
Fixed in
2.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Featured Image plugin for WordPress is vulnerable to Stored Cross-Site Scripting via image metadata in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-12019Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Featured Image vulnerability status badge
<a href="https://laskyr.com/plugins/featured-image"><img src="https://laskyr.com/plugins/featured-image/badge.svg" alt="Featured Image vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit