Plugins · feather-login-page · data as of 2026-11-04
Is Feather Login Page safe? Known vulnerabilities and latest version
- Status
- Closed 2025-12-04
- Known issues on record
- 6
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate feather-login-page && wp plugin delete feather-login-page
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 6 record(s) do not state which versions are affected.
medium 4.3 CVE-2025-62107 · published 2025-12-22
Cross-site request forgery (CSRF) in Feather Login Page (1.1.7 and older)
- Affected
- 1.1.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in PluginOps Feather Login Page feather-login-page allows Cross Site Request Forgery.This issue affects Feather Login Page: from n/a through <= 1.1.7.
medium 4.3 CVE-2024-31923 · published 2024-04-15
Cross-site request forgery (CSRF) in Feather Login Page (1.1.5 and older)
- Affected
- 1.1.5 and older
- Fixed in
- 1.1.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in PluginOps Feather Login Page.This issue affects Feather Login Page: from n/a through 1.1.5.
high 8.8 CVE-2023-46777 · published 2023-11-06
Cross-site request forgery (CSRF) in Feather Login Page (1.1.3 and older)
- Affected
- 1.1.3 and older
- Fixed in
- 1.1.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Custom Login Page | Temporary Users | Rebrand Login | Login Captcha plugin <= 1.1.3 versions.
high 8.8 CVE-2023-2545 · published 2023-05-31
Privilege escalation in Feather Login Page (1.0.7 to 1.1.1)
- Affected
- 1.0.7 to 1.1.1
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Feather Login Page plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'getListOfUsers' function in versions starting from 1.0.7 up to, and including, 1.1.1. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to access the login links, which can be used for privilege escalation.
medium 5.4 CVE-2023-2547 · published 2023-05-31
Missing authorization check in Feather Login Page (1.0.7 to 1.1.1)
- Affected
- 1.0.7 to 1.1.1
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Feather Login Page plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'deleteUser' function in versions starting from 1.0.7 up to, and including, 1.1.1. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to delete the temp user generated by the plugin.
high 8.8 CVE-2023-2549 · published 2023-05-31
Cross-site request forgery (CSRF) in Feather Login Page (1.0.7 to 1.1.1)
- Affected
- 1.0.7 to 1.1.1
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Feather Login Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions starting from 1.0.7 up to, and including, 1.1.1. This is due to missing nonce validation in the 'createTempAccountLink' function. This makes it possible for unauthenticated attackers to create a new user with administrator role via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. An attacker can leverage CVE-2023-2545 to get the login link or request a password reset to the new user's email address.
Recent activity
- 2025-12-04 — closed on wordpress.org (Guideline Violation).
- 2025-12-22 — Cross-site request forgery (CSRF) disclosed (CVE-2025-62107), fix version not stated.
- 2024-04-15 — Cross-site request forgery (CSRF) disclosed (CVE-2024-31923), fixed in 1.1.6.
- 2023-11-06 — Cross-site request forgery (CSRF) disclosed (CVE-2023-46777), fixed in 1.1.4.
Get an email when Feather Login Page has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Feather Login Page (feather-login-page) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (4) · Privilege escalation (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/feather-login-page (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/feather-login-page"><img src="https://laskyr.com/plugins/feather-login-page/badge.svg" alt="Feather Login Page vulnerability status"></a>