Plugins · fb-reviews-widget · data as of 2026-11-04
Is Reviews Widgets for Google, TripAdvisor, Yelp… safe? Known vulnerabilities and latest version
- Latest version
- 2.9
- Last updated
- 2026-09-26
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Combine Facebook reviews and recommendations with Google, TripAdvisor and Yelp reviews in a widget, block or shortcode. Build a trusted website! — by richplugins
What to do
- Update to the latest version (2.9). Anything older than 2.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get fb-reviews-widget --field=version shows what you run; wp plugin update fb-reviews-widget updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-12154 · published 2026-07-06
Stored cross-site scripting (XSS) in Reviews Widgets for Google, TripAdvisor, Yelp… (2.7.3 and older)
- Affected
- 2.7.3 and older
- Fixed in
- 2.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Reviews Widgets for Google, Yelp & TripAdvisor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'page_id' shortcode attribute of the [fbrev] shortcode in versions up to and including 2.7.3. This is due to insufficient input sanitization and output escaping in the Feed_Shortcode::fbrev() method, which passes the raw shortcode attribute through Feed_Old::get_feed() into the View::render() method, where it is echoed directly into the data-id HTML attribute without esc_attr(). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-12154Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2025-12705 · published 2025-12-09
Stored cross-site scripting (XSS) in Reviews Widgets for Google, TripAdvisor, Yelp… (2.5 and older)
- Affected
- 2.5 and older
- Fixed in
- 2.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.
NVD CVE-2025-12705Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-30883 · published 2025-03-27
Missing authorization check in Reviews Widgets for Google, TripAdvisor, Yelp… (2.3 and older)
- Affected
- 2.3 and older
- Fixed in
- 2.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in richplugins Trust.Reviews fb-reviews-widget allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Trust.Reviews: from n/a through <= 2.3.
Recent activity
- 2026-09-26 — latest release on wordpress.org (2.9).
- 2026-07-06 — Stored cross-site scripting (XSS) disclosed (CVE-2026-12154), fixed in 2.8.
- 2025-12-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12705), fixed in 2.6.
- 2025-03-27 — Missing authorization check disclosed (CVE-2025-30883), fixed in 2.4.
Get an email when Reviews Widgets for Google, TripAdvisor, Yelp… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Reviews Widgets for Google, TripAdvisor, Yelp… (fb-reviews-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by richplugins (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/fb-reviews-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/fb-reviews-widget"><img src="https://laskyr.com/plugins/fb-reviews-widget/badge.svg" alt="Reviews Widgets for Google, TripAdvisor, Yelp… vulnerability status"></a>