Skip to content
Laskyr

Plugins · favorites · data as of 2026-11-04

Is Favorites safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.8)

As of 2026-11-04. 4 issues are on record for older versions; version 2.3.7 or newer fixes all of them that state a fix.

Latest version
2.3.8
Last updated
2026-08-21
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.4+

Favorites for any post type. Easily add favoriting/liking, wishlists, or any other similar functionality using the developer-friendly API. — by Hook & Filter

What to do

  1. Update to the latest version (2.3.8). Anything older than 2.3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get favorites --field=version shows what you run; wp plugin update favorites updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-60202 · published 2025-11-06

File inclusion in Favorites (2.3.6 and older)

Affected
2.3.6 and older
Fixed in
2.3.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Kyle Phillips Favorites favorites allows PHP Local File Inclusion.This issue affects Favorites: from n/a through <= 2.3.6.

NVD CVE-2025-60202Patchstack advisory

low 3.5 CVE-2025-1452 · published 2025-03-25

Stored cross-site scripting (XSS) in Favorites (older than 2.3.5)

Affected
older than 2.3.5
Fixed in
2.3.5
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Favorites WordPress plugin before 2.3.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2025-1452WPScan advisory

medium 6.4 CVE-2024-2948 · published 2024-03-30

Stored cross-site scripting (XSS) in Favorites (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Favorites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'user_favorites' shortcode in all versions up to, and including, 2.3.3 due to insufficient input sanitization and output escaping on user supplied attributes such as 'no_favorites'. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2948Wordfence advisoryCode change (fix)

medium 5.4 CVE-2023-2304 · published 2023-05-31

Stored cross-site scripting (XSS) in Favorites (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Favorites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'user_favorites' shortcode in versions up to, and including, 2.3.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-2304Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Favorites vulnerability status badge
<a href="https://laskyr.com/plugins/favorites"><img src="https://laskyr.com/plugins/favorites/badge.svg" alt="Favorites vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit