Plugins · faustwp · data as of 2026-11-04
Is Faust.js safe? Known vulnerabilities and latest version
- Latest version
- 1.9.1
- Last updated
- 2026-10-26
- Active installs
- 1,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Faust.js™ transforms your traditional WordPress installation into a flexible headless CMS. — by WP Engine
What to do
- Update to the latest version (1.9.1). Anything older than 1.8.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get faustwp --field=version shows what you run; wp plugin update faustwp updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-49062 · published 2026-06-15
Authentication bypass in Faust.js (1.8.7 and older)
- Affected
- 1.8.7 and older
- Fixed in
- 1.8.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass Using an Alternate Path or Channel vulnerability in WP Engine Faust.Js allows Password Recovery Exploitation. This issue affects Faust.Js: from n/a through 1.8.7.
Recent activity
- 2026-10-26 — latest release on wordpress.org (1.9.1).
- 2026-06-15 — Authentication bypass disclosed (CVE-2026-49062), fixed in 1.8.8.
Get an email when Faust.js has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Faust.js (faustwp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WP Engine (5 tracked)
Types found in this plugin: Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/faustwp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/faustwp"><img src="https://laskyr.com/plugins/faustwp/badge.svg" alt="Faust.js vulnerability status"></a>