Skip to content
Laskyr

Plugins · fastdup · data as of 2026-11-04

Is FastDup safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.3)

As of 2026-11-04. 5 issues are on record for older versions; version 2.7.3 or newer fixes all of them that state a fix.

Latest version
2.7.3
Last updated
2026-08-23
Active installs
5,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

FastDup - Fastest WordPress Migration & Duplicator — by Ninja Team

What to do

  1. Update to the latest version (2.7.3). Anything older than 2.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fastdup --field=version shows what you run; wp plugin update fastdup updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.6 CVE-2026-52703 · published 2026-06-15

Path traversal / file read in FastDup (2.7.2 and older)

Affected
2.7.2 and older
Fixed in
2.7.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Path Traversal in FastDup <= 2.7.2 versions.

NVD CVE-2026-52703Patchstack advisory

high 8.8 CVE-2026-1104 · published 2026-02-12

Missing authorization check in FastDup (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
2.7.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FastDup – Fastest WordPress Migration & Duplicator plugin for WordPress is vulnerable to unauthorized backup creation and download due to a missing capability check on REST API endpoints in all versions up to, and including, 2.7.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to create and download full-site backup archives containing the entire WordPress installation, including database exports and configuration files.

NVD CVE-2026-1104Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-0604 · published 2026-01-06

Path traversal / file read in FastDup (2.7 and older)

Affected
2.7 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FastDup – Fastest WordPress Migration & Duplicator plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 2.7 via the 'dir_path' parameter in the 'njt-fastdup/v1/template/directory-tree' REST API endpoint. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary directories on the server, which can contain sensitive information.

NVD CVE-2026-0604Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2023-6592 · published 2024-01-16

Security issue in FastDup (older than 2.2)

Affected
older than 2.2
Fixed in
2.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The FastDup WordPress plugin before 2.2 does not prevent directory listing in sensitive directories containing export files.

NVD CVE-2023-6592WPScan advisoryresearch.cleantalk.org

high 7.5 CVE-2023-51406 · published 2024-01-08

Information disclosure in FastDup (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Ninja Team FastDup – Fastest WordPress Migration & Duplicator.This issue affects FastDup – Fastest WordPress Migration & Duplicator: from n/a through 2.1.7.

NVD CVE-2023-51406Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FastDup vulnerability status badge
<a href="https://laskyr.com/plugins/fastdup"><img src="https://laskyr.com/plugins/fastdup/badge.svg" alt="FastDup vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit