Plugins · fast-velocity-minify · data as of 2026-11-04
Is Fast Velocity Minify safe? Known vulnerabilities and latest version
- Latest version
- 3.5.8
- Last updated
- 2026-10-28
- Active installs
- 30,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Maximize GTmetrix, PageSpeed and enhance Web Vitals by minifying CSS/JS, lazy loading scripts, optimizing images, and improving load speed overall. — by Raul P.
What to do
- Update to the latest version (3.5.8). Anything older than 3.5.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get fast-velocity-minify --field=version shows what you run; wp plugin update fast-velocity-minify updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-48201 · published 2026-10-30
Cross-site scripting (XSS) in Fast Velocity Minify (3.5.7 and older)
- Affected
- 3.5.7 and older
- Fixed in
- 3.5.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Fast Velocity Minify <= 3.5.7 versions.
medium 4.4 CVE-2025-12034 · published 2025-10-25
Stored cross-site scripting (XSS) in Fast Velocity Minify (3.5.1 and older)
- Affected
- 3.5.1 and older
- Fixed in
- 3.5.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
NVD CVE-2025-12034Wordfence advisoryCode change (fix)github.com
Recent activity
- 2026-10-28 — latest release on wordpress.org (3.5.8).
- 2026-10-30 — Cross-site scripting (XSS) disclosed (CVE-2026-48201), fixed in 3.5.8.
- 2025-10-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12034), fixed in 3.5.2.
Get an email when Fast Velocity Minify has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Fast Velocity Minify (fast-velocity-minify) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/fast-velocity-minify (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/fast-velocity-minify"><img src="https://laskyr.com/plugins/fast-velocity-minify/badge.svg" alt="Fast Velocity Minify vulnerability status"></a>