Skip to content
Laskyr

Plugins · faq-builder-ays · data as of 2026-11-04

Is FAQ Builder AYS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.5)

As of 2026-11-04. 5 issues are on record for older versions; version 1.8.5 or newer fixes all of them that state a fix.

Latest version
1.8.5
Last updated
2026-08-28
Active installs
100+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Create FAQs and accordions for your WP website without effort with FAQ Builder. Has Gutenberg Block, responsive design, 20+ style options, etc. — by Ays Pro

What to do

  1. Update to the latest version (1.8.5). Anything older than 1.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get faq-builder-ays --field=version shows what you run; wp plugin update faq-builder-ays updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-81737 · published 2026-09-02

Stored cross-site scripting (XSS) in FAQ Builder AYS (1.6.3 up to (not including) 1.8.5)

Affected
1.6.3 up to (not including) 1.8.5
Fixed in
1.8.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The FAQ Builder AYS WordPress plugin before 1.8.5 does not sanitize or escape content submitted by unauthenticated visitors before storing it and outputting it in an admin area page, and the escaping it does apply is undone by a subsequent decoding step, leading to Stored XSS which will execute in the context of a logged in administrator.

NVD CVE-2026-81737WPScan advisory

high 7.1 CVE-2026-25346 · published 2026-03-25

Cross-site scripting (XSS) in FAQ Builder AYS (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro FAQ Builder AYS faq-builder-ays allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FAQ Builder AYS: from n/a through <= 1.8.2.

NVD CVE-2026-25346Patchstack advisory

medium 5.9 CVE-2025-24722 · published 2025-01-24

Stored cross-site scripting (XSS) in FAQ Builder AYS (1.7.3 and older)

Affected
1.7.3 and older
Fixed in
1.7.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro FAQ Builder AYS faq-builder-ays allows Stored XSS.This issue affects FAQ Builder AYS: from n/a through <= 1.7.3.

NVD CVE-2025-24722Patchstack advisory

medium 6.1 CVE-2024-11458 · published 2024-11-28

Reflected cross-site scripting (XSS) in FAQ Builder AYS (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.7.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FAQ Builder AYS plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'ays_faq_tab' parameter in all versions up to, and including, 1.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-11458Wordfence advisoryPlugin source

high 8.8 CVE-2021-24461 · published 2021-08-02

SQL injection in FAQ Builder AYS (older than 1.3.6)

Affected
older than 1.3.6
Fixed in
1.3.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by NVD
Details from the advisory

The get_faqs() function in the FAQ Builder AYS WordPress plugin before 1.3.6 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard

NVD CVE-2021-24461WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FAQ Builder AYS vulnerability status badge
<a href="https://laskyr.com/plugins/faq-builder-ays"><img src="https://laskyr.com/plugins/faq-builder-ays/badge.svg" alt="FAQ Builder AYS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit