Skip to content
Laskyr

Plugins · falang · data as of 2026-11-04

Is Falang multilanguage for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.6)

As of 2026-11-04. 8 issues are on record for older versions; version 1.4.3 or newer fixes all of them that state a fix.

Latest version
1.4.6
Last updated
2026-10-12
Active installs
1,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Falang is a WordPress multilingual plugin. Translate sites and WooCommerce content. Supports Google, Azure, DeepL and ChatGPT — by Stéphane Bouey

What to do

  1. Update to the latest version (1.4.6). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get falang --field=version shows what you run; wp plugin update falang updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-54805 · published 2026-06-17

Privilege escalation in Falang multilanguage for WordPress (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Privilege Escalation in Falang multilanguage <= 1.4.2 versions.

NVD CVE-2026-54805Patchstack advisory

high 8.8 CVE-2025-58619 · published 2025-11-06

PHP object injection in Falang multilanguage for WordPress (1.3.65 and older)

Affected
1.3.65 and older
Fixed in
1.3.66
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in sbouey Falang multilanguage falang allows Object Injection.This issue affects Falang multilanguage: from n/a through <= 1.3.65.

NVD CVE-2025-58619Patchstack advisory

medium 4.3 CVE-2025-48285 · published 2025-05-19

Cross-site request forgery (CSRF) in Falang multilanguage for WordPress (1.3.61 and older)

Affected
1.3.61 and older
Fixed in
1.3.62
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in sbouey Falang multilanguage falang allows Cross Site Request Forgery.This issue affects Falang multilanguage: from n/a through <= 1.3.61.

NVD CVE-2025-48285Patchstack advisory

medium 4.3 CVE-2024-37240 · published 2025-01-02

Cross-site request forgery (CSRF) in Falang multilanguage for WordPress (1.3.51 and older)

Affected
1.3.51 and older
Fixed in
1.3.52
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in sbouey Falang multilanguage falang allows Cross Site Request Forgery.This issue affects Falang multilanguage: from n/a through <= 1.3.51.

NVD CVE-2024-37240Patchstack advisory

high 7.1 CVE-2024-6869 · published 2024-08-08

Missing authorization check in Falang multilanguage for WordPress (1.3.52 and older)

Affected
1.3.52 and older
Fixed in
1.3.53 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Falang multilanguage for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 1.3.52. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update and delete translations and expose the administrator email address.

NVD CVE-2024-6869Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2024-4417 · published 2024-05-14

Stored cross-site scripting (XSS) in Falang multilanguage for WordPress (1.3.49 and older)

Affected
1.3.49 and older
Fixed in
1.3.50 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Falang multilanguage for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.3.49 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2024-4417Wordfence advisoryCode change (fix)

high 7.2 CVE-2024-30495 · published 2024-03-29

SQL injection in Falang multilanguage for WordPress (1.3.47 and older)

Affected
1.3.47 and older
Fixed in
1.3.48
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Faboba Falang multilanguage.This issue affects Falang multilanguage: from n/a through 1.3.47.

NVD CVE-2024-30495Patchstack advisory

high 8.8 CVE-2023-37968 · published 2023-07-17

Cross-site request forgery (CSRF) in Falang multilanguage for WordPress (1.3.39 and older)

Affected
1.3.39 and older
Fixed in
1.3.40
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Faboba Falang multilanguage for WordPress plugin <= 1.3.39 versions.

NVD CVE-2023-37968Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Falang multilanguage for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/falang"><img src="https://laskyr.com/plugins/falang/badge.svg" alt="Falang multilanguage for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit