Skip to content
Laskyr

Plugins · facebook-auto-publish · data as of 2026-11-04

Is WP2Social Auto Publish safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.13)

As of 2026-11-04. 2 issues are on record for older versions; version 2.4.13 or newer fixes all of them that state a fix.

Latest version
2.4.13
Last updated
2026-08-17
Active installs
9,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

Publish posts automatically to Facebook page. — by f1logic

What to do

  1. Update to the latest version (2.4.13). Anything older than 2.4.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get facebook-auto-publish --field=version shows what you run; wp plugin update facebook-auto-publish updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-12042 · published 2026-09-19

Stored cross-site scripting (XSS) in WP2Social Auto Publish (2.4.12 and older)

Affected
2.4.12 and older
Fixed in
2.4.13 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP2Social Auto Publish plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.4.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-12042Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2025-12064 · published 2025-11-08

Reflected cross-site scripting (XSS) in WP2Social Auto Publish (2.4.7 and older)

Affected
2.4.7 and older
Fixed in
2.4.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP2Social Auto Publish plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via PostMessage in all versions up to, and including, 2.4.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-12064Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP2Social Auto Publish vulnerability status badge
<a href="https://laskyr.com/plugins/facebook-auto-publish"><img src="https://laskyr.com/plugins/facebook-auto-publish/badge.svg" alt="WP2Social Auto Publish vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit