Plugins · ezoic-integration · data as of 2026-11-04
Is Ezoic safe? Known vulnerabilities and latest version
- Latest version
- 2.25.12
- Last updated
- 2026-10-27
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Ezoic plugin provides a simple and intuitive way to integrate and connect with the entire Ezoic technology platform for ad optimization and revenue gr … — by ezoic
What to do
- Update to the latest version (2.25.12). Anything older than 2.23.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ezoic-integration --field=version shows what you run; wp plugin update ezoic-integration updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-32481 · published 2026-08-18
Authentication bypass in Ezoic (2.22.11 and older)
- Affected
- 2.22.11 and older
- Fixed in
- 2.23.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Authentication in Ezoic <= 2.22.11 versions.
high 7.5 CVE-2026-18789 · published 2026-08-12
Missing authorization check in Ezoic (2.6.35 up to (not including) 2.23.1)
- Affected
- 2.6.35 up to (not including) 2.23.1
- Fixed in
- 2.23.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Ezoic WordPress plugin before 2.23.1 does not properly restrict access to some of its content export functionality, allowing unauthenticated attackers to trigger a server-side export of the site's database, including user password hashes and password reset tokens, as well as to persistently change some of its settings.
medium 4.8 CVE-2022-41315 · published 2022-11-17
Stored cross-site scripting (XSS) in Ezoic (2.8.8 and older)
- Affected
- 2.8.8 and older
- Fixed in
- 2.8.9 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. Stored Cross-Site Scripting (XSS) vulnerability in Ezoic plugin <= 2.8.8 on WordPress.
medium 6.1 CVE-2022-41132 · published 2022-11-17
Stored cross-site scripting (XSS) in Ezoic (2.8.8 and older)
- Affected
- 2.8.8 and older
- Fixed in
- 2.8.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauthenticated Plugin Settings Change Leading To Stored XSS Vulnerability in Ezoic plugin <= 2.8.8 on WordPress.
Recent activity
- 2026-10-27 — latest release on wordpress.org (2.25.12).
- 2026-08-18 — Authentication bypass disclosed (CVE-2026-32481), fixed in 2.23.1.
- 2026-08-12 — Missing authorization check disclosed (CVE-2026-18789), fixed in 2.23.1.
- 2022-11-17 — Stored cross-site scripting (XSS) disclosed (CVE-2022-41315), fixed in 2.8.9.
Get an email when Ezoic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ezoic (ezoic-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Authentication bypass (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ezoic-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ezoic-integration"><img src="https://laskyr.com/plugins/ezoic-integration/badge.svg" alt="Ezoic vulnerability status"></a>