Plugins · eyewear-prescription-form · data as of 2026-11-04
Is Eyewear prescription form safe? Known vulnerabilities and latest version
- Latest version
- 7.0.11
- Last updated
- 2026-10-11
- Active installs
- 10+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.0+
Eyewear prescription form plugin enabled you to add as many as lens, glasses and lens coatings to your products. — by dugudlabs
What to do
- Update to the latest version (7.0.11). Anything older than 7.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get eyewear-prescription-form --field=version shows what you run; wp plugin update eyewear-prescription-form updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-14365 · published 2025-12-13
Missing authorization check in Eyewear prescription form (6.0.1 and older)
- Affected
- 6.0.1 and older
- Fixed in
- 7.0.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Eyewear prescription form plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 6.0.1. This is due to missing capability checks on the RemoveItems AJAX action. This makes it possible for unauthenticated attackers to delete arbitrary WooCommerce product categories, including all of their child categories, via the 'catIds' parameter.
medium 5.3 CVE-2025-14366 · published 2025-12-13
Missing authorization check in Eyewear prescription form (6.0.1 and older)
- Affected
- 6.0.1 and older
- Fixed in
- 7.0.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Eyewear prescription form plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 6.0.1. This is due to missing authorization checks on the SubmitCatProductRequest AJAX action. This makes it possible for unauthenticated attackers to create arbitrary WooCommerce products with custom names, prices, and category assignments via the 'Name', 'Price', and 'Parent' parameters.
critical 9.8 CVE-2024-54239 · published 2024-12-13
Privilege escalation in Eyewear prescription form (4.0.18 and older)
- Affected
- 4.0.18 and older
- Fixed in
- 4.0.19
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in dugudlabs Eyewear prescription form eyewear-prescription-form allows Privilege Escalation.This issue affects Eyewear prescription form: from n/a through <= 4.0.18.
Recent activity
- 2026-10-11 — latest release on wordpress.org (7.0.11).
- 2025-12-13 — Missing authorization check disclosed (CVE-2025-14365), fixed in 7.0.0.
- 2025-12-13 — Missing authorization check disclosed (CVE-2025-14366), fixed in 7.0.0.
- 2024-12-13 — Privilege escalation disclosed (CVE-2024-54239), fixed in 4.0.19.
Get an email when Eyewear prescription form has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Eyewear prescription form (eyewear-prescription-form) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/eyewear-prescription-form (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/eyewear-prescription-form"><img src="https://laskyr.com/plugins/eyewear-prescription-form/badge.svg" alt="Eyewear prescription form vulnerability status"></a>