Skip to content
Laskyr

Plugins · extensions-for-elementor-form · data as of 2026-11-04

Is Cool FormKit Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.10)

As of 2026-11-04. 2 issues are on record for older versions; version 2.7.10 or newer fixes all of them that state a fix.

Latest version
2.7.10
Last updated
2026-10-29
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Contact form addon for Elementor. Create forms in Elementor Free or extend Elementor Pro forms with conditional logic, country code and extra fields. — by Cool Plugins

What to do

  1. Update to the latest version (2.7.10). Anything older than 2.7.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get extensions-for-elementor-form --field=version shows what you run; wp plugin update extensions-for-elementor-form updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-118500 · published 2026-10-30

DOM-based cross-site scripting (XSS) in Cool FormKit Lite (2.7.9 and older)

Affected
2.7.9 and older
Fixed in
2.7.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cool FormKit Lite – Advanced Form Builder for Elementor plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the '_elementor_data.form_fields[].custom_id' parameter in all versions up to, and including, 2.7.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The esc_html() call applied at server emission is bypassed because the HTML fragment-serialization algorithm restores " to a raw double-quote inside text nodes when jQuery .html() extracts the template, allowing the attacker-controlled custom_id to break out of an HTML attribute context within the plugin's own frontend script.

NVD CVE-2026-118500Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.5 CVE-2026-97301 · published 2026-09-30

Cross-site scripting (XSS) in Cool FormKit Lite (2.7.8 and older)

Affected
2.7.8 and older
Fixed in
2.7.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Cool Formkit Lite <= 2.7.8 versions.

NVD CVE-2026-97301Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cool FormKit Lite vulnerability status badge
<a href="https://laskyr.com/plugins/extensions-for-elementor-form"><img src="https://laskyr.com/plugins/extensions-for-elementor-form/badge.svg" alt="Cool FormKit Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit