Plugins · extensions-for-cf7 · data as of 2026-11-04
Is Extensions For CF7 (Contact form 7 Database, C… safe? Known vulnerabilities and latest version
- Latest version
- 3.4.6
- Last updated
- 2026-10-04
- Active installs
- 5,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Easily save contact form data, apply conditional logic in the fields and redirect to any page after contact form submission. — by HT Plugins
What to do
- Update to the latest version (3.4.6). Anything older than 3.4.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get extensions-for-cf7 --field=version shows what you run; wp plugin update extensions-for-cf7 updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-94589 · published 2026-10-10
Arbitrary file upload in Extensions For CF7 (Contact form 7 Database, C… (3.4.5 and older)
- Affected
- 3.4.5 and older
- Fixed in
- 3.4.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Extensions For CF7 (Contact form 7 Database, Conditional Fields and Redirection) plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 3.4.5 via the extcf7_submit function. This is due to missing file extension, MIME type, and size validation in the signature field's validation_filter(), combined with the absence of PHP-execution guards in the upload directory and a sanitize_file_name() bypass that converts shell.php- into shell.php. This makes it possible for unauthenticated attackers to upload files that may be executable, which makes remote code execution possible.
NVD CVE-2026-94589Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-24991 · published 2026-02-03
Missing authorization check in Extensions For CF7 (Contact form 7 Database, C… (3.4.0 and older)
- Affected
- 3.4.0 and older
- Fixed in
- 3.4.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in HT Plugins Extensions For CF7 extensions-for-cf7 allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Extensions For CF7: from n/a through <= 3.4.0.
high 8.1 CVE-2025-7645 · published 2025-07-22
Arbitrary file deletion in Extensions For CF7 (Contact form 7 Database, C… (3.2.8 and older)
- Affected
- 3.2.8 and older
- Fixed in
- 3.2.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Extensions For CF7 (Contact form 7 Database, Conditional Fields and Redirection) plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'delete-file' field in all versions up to, and including, 3.2.8. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, when an administrator deletes the submission, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
NVD CVE-2025-7645Wordfence advisoryCode change (fix)wordpress.org
medium 4.4 CVE-2025-24695 · published 2025-01-24
Server-side request forgery (SSRF) in Extensions For CF7 (Contact form 7 Database, C… (3.2.0 and older)
- Affected
- 3.2.0 and older
- Fixed in
- 3.2.1
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in HT Plugins Extensions For CF7 extensions-for-cf7 allows Server Side Request Forgery.This issue affects Extensions For CF7: from n/a through <= 3.2.0.
medium 6.1 CVE-2024-29102 · published 2024-03-19
Stored cross-site scripting (XSS) in Extensions For CF7 (Contact form 7 Database, C… (3.0.6 and older)
- Affected
- 3.0.6 and older
- Fixed in
- 3.0.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HasThemes Extensions For CF7 allows Stored XSS.This issue affects Extensions For CF7: from n/a through 3.0.6.
medium 4.3 CVE-2023-23899 · published 2023-02-17
Cross-site request forgery (CSRF) in Extensions For CF7 (Contact form 7 Database, C… (2.0.8 and older)
- Affected
- 2.0.8 and older
- Fixed in
- 2.0.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in HasThemes Extensions For CF7 plugin <= 2.0.8 versions leads to arbitrary plugin activation.
Recent activity
- 2026-10-04 — latest release on wordpress.org (3.4.6).
- 2026-10-10 — Arbitrary file upload disclosed (CVE-2026-94589), fixed in 3.4.6.
- 2026-02-03 — Missing authorization check disclosed (CVE-2026-24991), fixed in 3.4.1.
- 2025-07-22 — Arbitrary file deletion disclosed (CVE-2025-7645), fixed in 3.2.9.
Get an email when Extensions For CF7 (Contact form 7 Database, C… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Extensions For CF7 (Contact form 7 Database, C… (extensions-for-cf7) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by HT Plugins (6 tracked)
Types found in this plugin: Arbitrary file upload (1) · Missing authorization (1) · Arbitrary file deletion (1) · Server-side request forgery (SSRF) (1) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/extensions-for-cf7 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/extensions-for-cf7"><img src="https://laskyr.com/plugins/extensions-for-cf7/badge.svg" alt="Extensions For CF7 (Contact form 7 Database, C… vulnerability status"></a>