Plugins · extendify · data as of 2026-11-01
Is Extendify safe? Known vulnerabilities and latest version
- Latest version
- 3.2.4
- Last updated
- 2026-10-22
- Active installs
- 500,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 7.0+
The best WordPress templates, pattern, and layout library with 1,000+ designs built for the Gutenberg block editor. — by Extendify
What to do
- Update to the latest version (3.2.4). Anything older than 3.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get extendify --field=version shows what you run; wp plugin update extendify updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-85679 · published 2026-10-01
Stored cross-site scripting (XSS) in Extendify (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Extendify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'styles.blocks' Block Type Key in all versions up to, and including, 3.1.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because registerIncoming() is hooked on rest_request_before_callbacks and runs before WordPress evaluates the route's permission_callback, meaning any unauthenticated POST, PUT, or PATCH request to a /wp/v2/global-styles route can trigger the vulnerable code path.
NVD CVE-2026-85679Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-22 — latest release on wordpress.org (3.2.4).
- 2026-10-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-85679), fixed in 3.2.0.
Get an email when Extendify has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Extendify (extendify) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/extendify (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/extendify"><img src="https://laskyr.com/plugins/extendify/badge.svg" alt="Extendify vulnerability status"></a>