Plugins · extend-link · data as of 2026-11-04
Is Extend Link safe? Known vulnerabilities and latest version
- Latest version
- 2.0.2
- Last updated
- 2026-08-21
- Active installs
- 1,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Add classes, IDs, titles, rel attributes, and download options to links. Includes H1–H6 heading support and built-in link status checker for SEO. — by Alobaidi
What to do
- Update to the latest version (2.0.2). Anything older than 2.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get extend-link --field=version shows what you run; wp plugin update extend-link updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-25310 · published 2026-02-19
Server-side request forgery (SSRF) in Extend Link (2.0.0 and older)
- Affected
- 2.0.0 and older
- Fixed in
- 2.0.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Alobaidi Extend Link extend-link allows Server Side Request Forgery.This issue affects Extend Link: from n/a through <= 2.0.0.
Recent activity
- 2026-08-21 — latest release on wordpress.org (2.0.2).
- 2026-02-19 — Server-side request forgery (SSRF) disclosed (CVE-2026-25310), fixed in 2.0.1.
Get an email when Extend Link has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Extend Link (extend-link) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/extend-link (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/extend-link"><img src="https://laskyr.com/plugins/extend-link/badge.svg" alt="Extend Link vulnerability status"></a>