Plugins · expand-maker · data as of 2026-11-04
Is Read More & Accordion safe? Known vulnerabilities and latest version
- Status
- Closed 2026-05-14
- Known issues on record
- 6
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate expand-maker && wp plugin delete expand-maker
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 6 record(s) do not state which versions are affected.
high 8.8 CVE-2026-7467 · published 2026-05-20
Privilege escalation in Read More & Accordion (3.5.7 and older)
- Affected
- 3.5.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Read More & Accordion plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.5.7. This is due to the 'RadMoreAjax::importData' function not restricting which database tables can be written to during import and not properly validating the imported data. This makes it possible for authenticated attackers, with permission granted by the site owner through the plugin's role settings, to insert arbitrary rows into the 'wp_users' and 'wp_usermeta' tables, including the 'wp_capabilities' field, allowing them to create a new administrator account and gain administrator access to the site.
medium 4.9 CVE-2026-7472 · published 2026-05-20
SQL injection in Read More & Accordion (3.5.7 and older)
- Affected
- 3.5.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Read More & Accordion plugin for WordPress is vulnerable to time-based blind SQL Injection via the 'orderby' parameter in all versions up to, and including, 3.5.7. This is due to the use of esc_sql() without surrounding the value in quotes in an ORDER BY clause inside the getAllDataByLimit() and getAccordionAllDataByLimit() functions in ReadMoreData.php. The user-supplied $_GET['orderby'] value is only processed through esc_attr() (an HTML-escaping function) before being passed to these database functions, where esc_sql() is applied but the value is directly concatenated—unquoted—into the ORDER BY fragment of the SQL query before $wpdb->prepare() is called. Because esc_sql() only escapes quote characters and backslashes (which are irrelevant in an unquoted ORDER BY context), an attacker can inject arbitrary SQL expressions such as (SELECT SLEEP(5)) or conditional subqueries to perform time-based blind data extraction. This makes it possible for authenticated attackers with administrator-level access or above (or any role explicitly permitted access to the plugin's admin pages via the yrm-user-roles setting) to extract sensitive data from the database, including administrator credential hashes.
medium 4.3 CVE-2025-64247 · published 2025-12-16
Missing authorization check in Read More & Accordion (3.5.5.1 and older)
- Affected
- 3.5.5.1 and older
- Fixed in
- 3.5.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in edmon.parker Read More & Accordion expand-maker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Read More & Accordion: from n/a through <= 3.5.5.1.
high 7.5 CVE-2025-0810 · published 2025-04-05
Cross-site request forgery (CSRF) in Read More & Accordion (3.4.7 and older)
- Affected
- 3.4.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Read More & Accordion plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.4.7. This is due to missing or incorrect nonce validation on the addNewButtons() function. This makes it possible for unauthenticated attackers to include and execute arbitrary PHP files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-0810Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2024-13639 · published 2025-02-13
Missing authorization check in Read More & Accordion (3.4.2 and older)
- Affected
- 3.4.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Read More & Accordion plugin for WordPress is vulnerable to unauthorized modification and loss of data due to a missing capability check on the expmDeleteData() function in all versions up to, and including, 3.4.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary 'read more' posts.
NVD CVE-2024-13639Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 7.2 CVE-2023-3392 · published 2023-10-16
PHP object injection in Read More & Accordion (older than 3.2.7)
- Affected
- older than 3.2.7
- Fixed in
- 3.2.7
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Read More & Accordion WordPress plugin before 3.2.7 unserializes user input provided via the settings, which could allow high-privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Recent activity
- 2026-05-14 — closed on wordpress.org (Security Issue).
- 2026-05-20 — Privilege escalation disclosed (CVE-2026-7467), fix version not stated.
- 2026-05-20 — SQL injection disclosed (CVE-2026-7472), fix version not stated.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-64247), fixed in 3.5.6.
Get an email when Read More & Accordion has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Read More & Accordion (expand-maker) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Privilege escalation (1) · SQL injection (1) · Cross-site request forgery (CSRF) (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/expand-maker (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/expand-maker"><img src="https://laskyr.com/plugins/expand-maker/badge.svg" alt="Read More & Accordion vulnerability status"></a>