Skip to content
Laskyr

Plugins · events-listing-widget · data as of 2026-11-04

Is Events Listing Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.5)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.5 or newer fixes all of them that state a fix.

Latest version
1.3.5
Last updated
2026-02-01
Active installs
60+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Create a list of upcoming events and display them using an easy-to-use widget — by Yannick Lefebvre

What to do

  1. Update to the latest version (1.3.5). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get events-listing-widget --field=version shows what you run; wp plugin update events-listing-widget updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1252 · published 2026-02-06

Stored cross-site scripting (XSS) in Events Listing Widget (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Events Listing Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Event URL' parameter in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1252Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Events Listing Widget vulnerability status badge
<a href="https://laskyr.com/plugins/events-listing-widget"><img src="https://laskyr.com/plugins/events-listing-widget/badge.svg" alt="Events Listing Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit