Plugins · events-for-geodirectory · data as of 2026-11-04
Is Events Calendar for GeoDirectory safe? Known vulnerabilities and latest version
- Latest version
- 2.3.34
- Last updated
- 2026-10-14
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Events Calendar add-on for GeoDirectory allows to extend your GeoDirectory powered website with a versatile event manager. — by Stiofan
What to do
- Update to the latest version (2.3.34). Anything older than 2.3.29 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get events-for-geodirectory --field=version shows what you run; wp plugin update events-for-geodirectory updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-39532 · published 2026-06-15
PHP object injection in Events Calendar for GeoDirectory (2.3.25 and older)
- Affected
- 2.3.25 and older
- Fixed in
- 2.3.26
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor PHP Object Injection in Events Calendar for GeoDirectory <= 2.3.25 versions.
high 8.8 CVE-2026-11616 · published 2026-06-09
Privilege escalation in Events Calendar for GeoDirectory (2.3.28 and older)
- Affected
- 2.3.28 and older
- Fixed in
- 2.3.29 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Events Calendar for GeoDirectory plugin for WordPress is vulnerable to Privilege Escalation in versions up to and including 2.3.28. This is due to the ajax_ayi_action() handler only applying strip_tags(esc_sql()) — with no allow-list — to the attacker-controlled $_POST['type'] and $_POST['postid'] values before forwarding them to update_ayi_data(), which calls update_user_meta($current_user->ID, $rsvp_args['type'], $posts). By passing type=wp_capabilities and postid=administrator, an attacker writes ['subscriber'=>true,'administrator'=>'administrator'] into their own wp_capabilities user meta; WP_User::get_role_caps() then treats the 'administrator' array key as an active role on the next request. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to Administrator.
NVD CVE-2026-11616Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2025-26967 · published 2025-03-03
PHP object injection in Events Calendar for GeoDirectory (2.3.14 and older)
- Affected
- 2.3.14 and older
- Fixed in
- 2.3.15
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in Stiofan Events Calendar for GeoDirectory events-for-geodirectory allows Object Injection.This issue affects Events Calendar for GeoDirectory: from n/a through <= 2.3.14.
Recent activity
- 2026-10-14 — latest release on wordpress.org (2.3.34).
- 2026-06-15 — PHP object injection disclosed (CVE-2026-39532), fixed in 2.3.26.
- 2026-06-09 — Privilege escalation disclosed (CVE-2026-11616), fixed in 2.3.29.
- 2025-03-03 — PHP object injection disclosed (CVE-2025-26967), fixed in 2.3.15.
Get an email when Events Calendar for GeoDirectory has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Events Calendar for GeoDirectory (events-for-geodirectory) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Stiofan (4 tracked)
Types found in this plugin: PHP object injection (2) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/events-for-geodirectory (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/events-for-geodirectory"><img src="https://laskyr.com/plugins/events-for-geodirectory/badge.svg" alt="Events Calendar for GeoDirectory vulnerability status"></a>