Skip to content
Laskyr

Plugins · event-organiser · data as of 2026-11-04

Is Event Organiser safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.12.12)

As of 2026-11-04. 2 issues are on record for older versions; version 3.12.10 or newer fixes all of them that state a fix.

Latest version
3.12.12
Last updated
2026-10-30
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Create and maintain events, including complex reoccurring patterns, venue management (with Google Maps or OpenStreetMap), calendars and customisable e … — by Stephen Harris

What to do

  1. Update to the latest version (3.12.12). Anything older than 3.12.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get event-organiser --field=version shows what you run; wp plugin update event-organiser updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-2387 · published 2026-07-01

Stored cross-site scripting (XSS) in Event Organiser (3.12.9 and older)

Affected
3.12.9 and older
Fixed in
3.12.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Event Organiser plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.12.9. This is due to the 'eo_events' shortcode accepting attacker-controlled 'no_events' content and rendering it in event list templates without output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2387Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-69012 · published 2025-12-30

Missing authorization check in Event Organiser (3.12.8 and older)

Affected
3.12.8 and older
Fixed in
3.12.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Stephen Harris Event Organiser event-organiser allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Event Organiser: from n/a through <= 3.12.8.

NVD CVE-2025-69012Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Event Organiser vulnerability status badge
<a href="https://laskyr.com/plugins/event-organiser"><img src="https://laskyr.com/plugins/event-organiser/badge.svg" alt="Event Organiser vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit