Skip to content
Laskyr

Plugins · event-monster · data as of 2026-11-04

Is Event Monster safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.2)

As of 2026-11-04. 7 issues are on record for older versions; version 2.1.1 or newer fixes all of them that state a fix.

Latest version
2.1.2
Last updated
2026-10-05
Active installs
600+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Comprehensive event manager plugin for event booking, event registration, event ticket management, and interactive calendar display. — by A WP Life

What to do

  1. Update to the latest version (2.1.2). Anything older than 2.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get event-monster --field=version shows what you run; wp plugin update event-monster updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-8608 · published 2026-06-06

Security issue in Event Monster (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Event Monster – Event Management, Events Calendar, Tickets plugin for WordPress is vulnerable to Insufficient Verification of Data Authenticity in versions up to, and including, 2.1.0. This is due to the capture_payment() AJAX handler (registered via wp_ajax_nopriv_em_capture_payment) trusting client-supplied payment data — including transaction ID, amount, and payment status — without performing any server-side verification against the PayPal API or any other payment gateway, and without nonce or capability checks. This makes it possible for unauthenticated attackers to forge payment records, mark bookings as Completed, and obtain confirmation emails containing valid QR code tickets without making any actual payment.

NVD CVE-2026-8608Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2024-11396 · published 2025-01-14

Information disclosure in Event Monster (1.4.3 and older)

Affected
1.4.3 and older
Fixed in
1.4.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Event Monster – Event Management, Tickets Booking, Upcoming Event plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.4.3 via the Visitors List Export file. During the export, a CSV file is created in the wp-content folder with a hardcoded filename that is publicly accessible. This makes it possible for unauthenticated attackers to extract data about event visitors, that includes first and last names, email, and phone number.

NVD CVE-2024-11396Wordfence advisoryPlugin source

high 7.5 CVE-2024-5059 · published 2024-06-21

Information disclosure in Event Monster (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in A WP Life Event Management Tickets Booking.This issue affects Event Management Tickets Booking: from n/a through 1.4.0.

NVD CVE-2024-5059Patchstack advisory

high 7.5 CVE-2024-1895 · published 2024-04-30

PHP object injection in Event Monster (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Event Monster – Event Management, Tickets Booking, Upcoming Event plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3.9 via deserialization via shortcode of untrusted input from a custom meta value. This makes it possible for authenticated attackers, with contributor access and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2024-1895Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-47525 · published 2023-12-21

Stored cross-site scripting (XSS) in Event Monster (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in A WP Life Event Monster – Event Management, Tickets Booking, Upcoming Event allows Stored XSS.This issue affects Event Monster – Event Management, Tickets Booking, Upcoming Event: from n/a through 1.3.2.

NVD CVE-2023-47525Patchstack advisory

medium 4.3 CVE-2022-3336 · published 2022-11-21

Cross-site request forgery (CSRF) in Event Monster (older than 1.2.0)

Affected
older than 1.2.0
Fixed in
1.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Event Monster WordPress plugin before 1.2.0 does not have CSRF check when deleting visitors, which could allow attackers to make logged in admin delete arbitrary visitors via a CSRF attack

NVD CVE-2022-3336WPScan advisory

high 7.2 CVE-2022-3720 · published 2022-11-21

SQL injection in Event Monster (older than 1.2.0)

Affected
older than 1.2.0
Fixed in
1.2.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Event Monster WordPress plugin before 1.2.0 does not validate and escape some parameters before using them in SQL statements, which could lead to SQL Injection exploitable by high privilege users

NVD CVE-2022-3720WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Event Monster vulnerability status badge
<a href="https://laskyr.com/plugins/event-monster"><img src="https://laskyr.com/plugins/event-monster/badge.svg" alt="Event Monster vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit