Skip to content
Laskyr

Plugins · event-espresso-decaf · data as of 2026-11-04

Is Event Espresso safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.0.59.decaf)

As of 2026-11-04. 5 issues are on record for older versions.

Latest version
5.0.59.decaf
Last updated
2026-09-11
Active installs
500+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The best events plugin with event registration, free and paid ticket sales, event registration forms, PayPal payments, automatic emails, and more! — by Event Espresso

What to do

  1. Update to the latest version (5.0.59.decaf). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get event-espresso-decaf --field=version shows what you run; wp plugin update event-espresso-decaf updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.

medium 6.5 CVE-2025-68007 · published 2026-01-22

Missing authorization check in Event Espresso (5.0.37 and older)

Affected
5.0.37 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Event Espresso Event Espresso 4 Decaf event-espresso-decaf allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Event Espresso 4 Decaf: from n/a through <= 5.0.37.decaf.

NVD CVE-2025-68007Patchstack advisory

medium 4.3 CVE-2024-56251 · published 2025-01-02

Cross-site request forgery (CSRF) in Event Espresso (5.0.28 and older)

Affected
5.0.28 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Event Espresso Event Espresso 4 Decaf event-espresso-decaf allows Cross Site Request Forgery.This issue affects Event Espresso 4 Decaf: from n/a through <= 5.0.28.decaf.

NVD CVE-2024-56251Patchstack advisory

medium 4.3 CVE-2024-6883 · published 2024-08-21

Missing authorization check in Event Espresso (4.10.46 and older)

Affected
4.10.46 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Wordfence
Details from the advisory

The Event Espresso 4 Decaf – Event Registration Event Ticketing plugin for WordPress is vulnerable to limited unauthorized plugin settings modification due to a missing capability check on the saveTimezoneString and some other functions in all versions up to and including 4.10.46.decaf. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify some of the plugin settings.

NVD CVE-2024-6883Wordfence advisoryPlugin source

low 3.7 CVE-2023-27437 · published 2024-06-03

Missing authorization check in Event Espresso (4.10.44 and older)

Affected
4.10.44 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Event Espresso Event Espresso 4 Decaf allows Functionality Misuse.This issue affects Event Espresso 4 Decaf: from n/a through 4.10.44.Decaf.

NVD CVE-2023-27437Patchstack advisory

medium 4.3 CVE-2021-4404 · published 2023-07-01

Cross-site request forgery (CSRF) in Event Espresso (4.10.11 and older)

Affected
4.10.11 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Event Espresso 4 Decaf plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.10.11. This is due to missing or incorrect nonce validation on the ajaxHandler() function. This makes it possible for unauthenticated attackers to op into notifications via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2021-4404Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Event Espresso vulnerability status badge
<a href="https://laskyr.com/plugins/event-espresso-decaf"><img src="https://laskyr.com/plugins/event-espresso-decaf/badge.svg" alt="Event Espresso vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit