Skip to content
Laskyr

Plugins · etruel-del-post-copies · data as of 2026-11-04

Is WP Delete Post Copies safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.0.3)

As of 2026-11-04. 2 issues are on record for older versions; version 6.0.3 or newer fixes all of them that state a fix.

Latest version
6.0.3
Last updated
2025-11-12
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

Delete duplicate posts by title or content, including attachments, with powerful filters. Supports manual and scheduled cleanups. — by etruel

What to do

  1. Update to the latest version (6.0.3). Anything older than 6.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get etruel-del-post-copies --field=version shows what you run; wp plugin update etruel-del-post-copies updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2025-12066 · published 2025-11-21

Stored cross-site scripting (XSS) in WP Delete Post Copies (6.0.2 and older)

Affected
6.0.2 and older
Fixed in
6.0.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Delete Post Copies plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 6.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-12066Wordfence advisoryCode change (fix)

medium 5.4 CVE-2025-22541 · published 2025-01-07

Missing authorization check in WP Delete Post Copies (5.5 and older)

Affected
5.5 and older
Fixed in
6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in etruel WP Delete Post Copies etruel-del-post-copies allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Delete Post Copies: from n/a through <= 5.5.

NVD CVE-2025-22541Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Delete Post Copies vulnerability status badge
<a href="https://laskyr.com/plugins/etruel-del-post-copies"><img src="https://laskyr.com/plugins/etruel-del-post-copies/badge.svg" alt="WP Delete Post Copies vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit