Plugins · ethpress · data as of 2026-11-04
Is EthPress safe? Known vulnerabilities and latest version
- Latest version
- 3.2.2
- Last updated
- 2026-11-01
- Active installs
- 90+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
EthPress Web3 Login Wordpress Plugin adds the capability to connect with cryptocurrency wallets such as MetaMask or Reown QR code. — by lynn999
What to do
- Update to the latest version (3.2.2). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ethpress --field=version shows what you run; wp plugin update ethpress updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2026-19125 · published 2026-09-23
Authentication bypass in EthPress (2.3.5 and older)
- Affected
- 2.3.5 and older
- Fixed in
- 3.2.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The EthPress – Web3 Login plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 2.3.5. This is due to the verify_login() function in app/Login.php containing a missing return statement in the signature verification failure branch — when Signature::verify2() reports a mismatch, the function only assigns a WP_Error to a local variable and continues executing, causing unconditional fall-through to the login block where Address::log_in() calls wp_set_auth_cookie() regardless of whether the submitted signature is valid. This makes it possible for unauthenticated attackers to log in as any WordPress user who has a linked wallet address — including administrators — by submitting that user's public wallet address alongside an arbitrary well-formed signature, enabling full site takeover.
NVD CVE-2026-19125Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-01 — latest release on wordpress.org (3.2.2).
- 2026-09-23 — Authentication bypass disclosed (CVE-2026-19125), fixed in 3.2.1.
Get an email when EthPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for EthPress (ethpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ethpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ethpress"><img src="https://laskyr.com/plugins/ethpress/badge.svg" alt="EthPress vulnerability status"></a>