Skip to content
Laskyr

Plugins · essential-widgets · data as of 2026-11-04

Is Essential Widgets safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.1 or newer fixes all of them that state a fix.

Latest version
3.2.1
Last updated
2026-06-18
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Essential Widgets is a WordPress plugin for widgets that allows you to create and add amazing widgets with high customization option — by Catch Themes

What to do

  1. Update to the latest version (3.2.1). Anything older than 3.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get essential-widgets --field=version shows what you run; wp plugin update essential-widgets updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-0867 · published 2026-02-05

Stored cross-site scripting (XSS) in Essential Widgets (3.0 and older)

Affected
3.0 and older
Fixed in
3.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Essential Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ew-author, ew-archive, ew-category, ew-page, and ew-menu shortcodes in all versions up to, and including, 3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 3.0.

NVD CVE-2026-0867Wordfence advisoryCode change (fix)

medium 6.5 CVE-2025-67543 · published 2025-12-09

Stored cross-site scripting (XSS) in Essential Widgets (2.2.2 and older)

Affected
2.2.2 and older
Fixed in
2.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Catch Themes Essential Widgets essential-widgets allows Stored XSS.This issue affects Essential Widgets: from n/a through <= 2.2.2.

NVD CVE-2025-67543Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Essential Widgets vulnerability status badge
<a href="https://laskyr.com/plugins/essential-widgets"><img src="https://laskyr.com/plugins/essential-widgets/badge.svg" alt="Essential Widgets vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit